Skip to main content
ExploitedIn CISA KEVFix available

CVE-2023-23752

Exploitation confirmed. First attested on 2023-10-13 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2023-02-16
  • Fixed in4.2.8
  • WeaknessCWE-284

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue was discovered in Joomla! 4.0.0 through 4.2.7. An improper access check allows unauthorized access to webservice endpoints.

Timeline

dates in UTC
  1. 2023-02-1617:15CVE publishedNVD
  2. 2023-04-08Exploit-DB entryExploit-DB
  3. 2023-10-1316:00Listed as exploited by GCVEGCVE
  4. 2023-10-1316:00Exploitation first reportedGCVE
  5. 2024-01-08Added to the CISA KEV catalogCISA KEV
  6. 2024-07-2420:52SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2023-23752?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2023-23752?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV · CISA-ADP
Joomla
BranchAffectedFixed in
4.x≥ 4.0.0, < 4.2.84.2.8
4.x≥ 4.0.0, ≤ 4.2.7no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As Joomla, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Joomla! Project Joomla! CMSother versions: not affected
    Affected
    • = 4.0.0-4.2.7no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-02-26

Fix

  1. Update Joomla to 4.2.8
  2. CISA’s required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.due 2024-01-29

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-51334
Exploit-DB
Metasploit modules
1 moduleauxiliary/scanner/http/joomla_api_improper_access_checksrank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2024-01-08
Patch Due Date
2024-01-29
Ransomware Use
Unknown
Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Published
2023-02-16
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-jmc9-376w-885v

Frequently asked questions

What is CVE-2023-23752?

An issue was discovered in Joomla! 4.0.0 through 4.2.7. An improper access check allows unauthorized access to webservice endpoints.

Is CVE-2023-23752 actively exploited?

Yes. CVE-2023-23752 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2024-01-29.

What is the CVSS score for CVE-2023-23752?

CVE-2023-23752 has a CVSS v3 base score of 5.3 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N.

Running Joomla? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record