CVE-2022-3900
A public proof of concept exists; no exploitation attested.
- Published2022-12-12
- Fixed in1.7.5.7
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
The Cooked Pro WordPress plugin before 1.7.5.7 does not properly validate or sanitize the recipe_args parameter before unserializing it in the cooked_loadmore action, allowing an unauthenticated attacker to trigger a PHP Object injection vulnerability.
Timeline
dates in UTC- 2022-12-1218:15CVE publishedNVD
Observed activity
isMalicious corpus · updated 2026-11-03 21:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-3900?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-3900?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 1.7 | < 1.7.5.7 | 1.7.5.7 | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA1 product
As WPScan, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- Unknown Cooked Proother versions: not affectedAffected
- < 1.7.5.7fixed in 1.7.5.7custom
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-12-12
Fix
- Update Boxystudio cooked to 1.7.5.7
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- CISA-ADPSSVC decisionpoc2025-04-22
- OpenCVESSVC decisionpoc—
- CISA-ADPCVSS 3.19.82025-04-22
- NVDCVSS 3.19.8read 2026-10-23
- FIRST EPSSEPSS score19.0 %read 2026-11-02
- GitHub Advisoriesadvisory—
Identifiers
- EUVD-2022-43236same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-gx5q-2vpf-g2w4same flawGitHub Advisory Database · CC-BY-4.0
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Published
- 2022-12-12
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-gx5q-2vpf-g2w4
Frequently asked questions
What is CVE-2022-3900?
Is CVE-2022-3900 actively exploited?
What is the CVSS score for CVE-2022-3900?
Hear about the next vulnerability in your software
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-gx5q-2vpf-g2w4
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- CISA Vulnrichment · CC0-1.0