Skip to main content
ExploitedNot in CISA KEV yetFix available

CVE-2022-3481

Exploitation confirmed. First attested on 2025-07-21 by GCVE · kevintel, GCVE · shadowserver.

  • Published2022-11-07
  • Fixed in4.4
  • WeaknessCWE-89

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The WooCommerce Dropshipping WordPress plugin before 4.4 does not properly sanitise and escape a parameter before using it in a SQL statement via a REST endpoint available to unauthenticated users, leading to a SQL injection

Timeline

dates in UTC
  1. 2022-11-0710:15CVE publishedNVD
  2. 2025-07-2101:58Listed as exploited by GCVEGCVE
  3. 2025-07-2101:58Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-3481?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-3481?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Opmc woocommerce dropshipping
BranchAffectedFixed in
4.4< 4.44.4

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As WPScan, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Unknown WooCommerce Dropshippingother versions: not affected
    Affected
    • < 4.4fixed in 4.4custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-01-10

Fix

  1. Update Opmc woocommerce dropshipping to 4.4

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-11-07
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-m4wm-6gf3-2xqw

Frequently asked questions

What is CVE-2022-3481?

The WooCommerce Dropshipping WordPress plugin before 4.4 does not properly sanitise and escape a parameter before using it in a SQL statement via a REST endpoint available to unauthenticated users, leading to a SQL injection

Is CVE-2022-3481 actively exploited?

A proof-of-concept exploit exists for CVE-2022-3481, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2022-3481?

CVE-2022-3481 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record