CVE-2022-28615
No exploitation reported by the sources we read.
- Published2022-06-09
- Fixed in2.4.54
- WeaknessCWE-190
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
Apache HTTP Server 2.4.53 and earlier may crash or disclose information due to a read beyond bounds in ap_strcmp_match() when provided with an extremely large input buffer. While no code distributed with the server can be coerced into such a call, third-party modules or lua scripts that use ap_strcmp_match() may hypothetically be affected.
Timeline
dates in UTC- 2022-06-0917:15CVE publishedNVD
Observed activity
isMalicious corpus · updated 2026-10-27 21:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-28615?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-28615?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD · OSV| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 2.4 | < 2.4.54 | 2.4.54 | NVD · OSV |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 35.x | = 35 | no fix published | NVD |
| 36.x | = 36 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| — | all versions | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- httpdAlmaLinux:9all versions · fixed in 2.4.53-7.el9and 8 other packages
- httpdAlmaLinux:8all versions · fixed in 2.4.37-51.module_el8.7.0+3281+01e58653and 6 other packages
- mod_http2AlmaLinux:8all versions · fixed in 1.15.7-5.module_el8.6.0+2872+fe0ff7aa
- mod_http2AlmaLinux:8all versions · fixed in 1.15.7-5.module_el8.6.0+3031+fb177b09
- mod_mdAlmaLinux:8all versions · fixed in 1:2.0.8-8.module_el8.6.0+2872+fe0ff7aa
- mod_mdAlmaLinux:8all versions · fixed in 1:2.0.8-8.module_el8.6.0+3031+fb177b09
- mod_sslAlmaLinux:9all versions · fixed in 1:2.4.53-7.el9and 1 other package
- mod_sslAlmaLinux:8all versions · fixed in 1:2.4.37-51.module_el8.7.0+3281+01e58653and 1 other package
Fix
- Update Apache HTTP Server to 2.4.54
Advisories and patches
- httpd.apache.orgVendor Advisory
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
Sources
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- Published
- 2022-06-09
- Last Modified
- 2026-06-17
- NVD status
- Modified
Frequently asked questions
What is CVE-2022-28615?
Is CVE-2022-28615 actively exploited?
What is the CVSS score for CVE-2022-28615?
Running Apache HTTP Server? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.