CVE-2022-26134
Exploitation confirmed. First attested on 2022-06-02 by CISA-ADP, CISA KEV, GCVE · enisa-cnw-kev, GCVE · kevintel, GCVE · shadowserver.
- Published2022-06-03
- Fixed in7.17.4 · 7.16.4 · 7.15.2 · 7.14.3 · 7.13.7 · 7.4.17
- WeaknessCWE-917
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
In affected versions of Confluence Server and Data Center, an OGNL injection vulnerability exists that would allow an unauthenticated attacker to execute arbitrary code on a Confluence Server or Data Center instance. The affected versions are from 1.3.0 before 7.4.17, from 7.13.0 before 7.13.7, from 7.14.0 before 7.14.3, from 7.15.0 before 7.15.2, from 7.16.0 before 7.16.4, from 7.17.0 before 7.17.4, and from 7.18.0 before 7.18.1.
Timeline
dates in UTC- 2022-06-02Added to the CISA KEV catalogCISA KEV
- 2022-06-02Listed as exploited by GCVEGCVE
- 2022-06-02Exploitation first reportedCISA KEV
- 2022-06-0322:15CVE publishedNVD
- 2022-06-10Exploit-DB entryExploit-DB
- 2025-02-0414:18SSVC exploitation set to activeCISA-ADP
Observed activity
isMalicious corpus · updated 2026-11-03 15:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-26134?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-26134?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 7.17 | ≥ 7.17.0, < 7.17.4 | 7.17.4 | NVD |
| 7.16 | ≥ 7.16.0, < 7.16.4 | 7.16.4 | NVD |
| 7.15 | ≥ 7.15.0, < 7.15.2 | 7.15.2 | NVD |
| 7.14 | ≥ 7.14.0, < 7.14.3 | 7.14.3 | NVD |
| 7.13 | ≥ 7.13.0, < 7.13.7 | 7.13.7 | NVD |
| 7.4 | ≥ 1.3, < 7.4.17 | 7.4.17 | NVD |
| 7.18 | = 7.18.0 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 7.17 | ≥ 7.17.0, < 7.17.4 | 7.17.4 | NVD |
| 7.16 | ≥ 7.16.0, < 7.16.4 | 7.16.4 | NVD |
| 7.15 | ≥ 7.15.0, < 7.15.2 | 7.15.2 | NVD |
| 7.14 | ≥ 7.14.0, < 7.14.3 | 7.14.3 | NVD |
| 7.13 | ≥ 7.13.0, < 7.13.7 | 7.13.7 | NVD |
| 7.4 | ≥ 1.3, < 7.4.17 | 7.4.17 | NVD |
| 7.18 | = 7.18.0 | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA2 products
As atlassian, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- Atlassian Confluence Data CenterAffected
- = next of 1.3.0no fix statedcustom
- < 7.4.17fixed in 7.4.17custom
- = 7.13.0no fix statedcustom
- < 7.13.7fixed in 7.13.7custom
- = 7.14.0no fix statedcustom
- < 7.14.3fixed in 7.14.3custom
- = 7.15.0no fix statedcustom
- < 7.15.2fixed in 7.15.2custom
6 more version lines in the CVE record.
- Atlassian Confluence ServerAffected
- = next of 1.3.0no fix statedcustom
- < 7.4.17fixed in 7.4.17custom
- = 7.13.0no fix statedcustom
- < 7.13.7fixed in 7.13.7custom
- = 7.14.0no fix statedcustom
- < 7.14.3fixed in 7.14.3custom
- = 7.15.0no fix statedcustom
- < 7.15.2fixed in 7.15.2custom
6 more version lines in the CVE record.
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-06-30
Fix
- Update Atlassian Confluence to 7.17.4 · 7.16.4 · 7.15.2 · 7.14.3 · 7.13.7 · 7.4.17
- CISA’s required action: Immediately block all internet traffic to and from affected products AND apply the update per vendor instructions [https://confluence.atlassian.com/doc/confluence-security-advisory-2022-06-02-1130377146.html] OR remove the affected products by the due date on the right. Note: Once the update is successfully deployed, agencies can reassess the internet blocking rules.due 2022-06-06
Advisories and patches
- confluence.atlassian.comVendor Advisory
- jira.atlassian.comPatch · Vendor Advisory
Detection
read 2026-11-02 22:42 UTC- Nuclei template
- available ProjectDiscovery
- Proof-of-concept repositories
- 20 repositories, unverifiedW01fh4cker/Sereinofflinehoster/CVE-2022-26134ma1am/CVE-2022-26134-Exploit-Detectionjbaines-r7/through_the_wirecrowsec-edtech/CVE-2022-26134 PoC-in-GitHub
- Metasploit modules
- 1 moduleexploit/multi/http/atlassian_confluence_namespace_ognl_injectionrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause. Metasploit Framework
CISA Known Exploited Vulnerability
- Date Added
- 2022-06-02
- Patch Due Date
- 2022-06-06
- Ransomware Use
- Known
- Required Action
- Immediately block all internet traffic to and from affected products AND apply the update per vendor instructions [https://confluence.atlassian.com/doc/confluence-security-advisory-2022-06-02-1130377146.html] OR remove the affected products by the due date on the right. Note: Once the update is successfully deployed, agencies can reassess the internet blocking rules.
Sources
- CISA KEVKEV entry2022-06-02
- ENISA EUVDexploitation2022-06-022022-06-02
- GCVEexploitation2022-06-02
- CISA-ADPSSVC decisionactive2025-02-04
- OpenCVESSVC decisionactive—
- CISA-ADPCVSS 3.19.82025-02-04
- NVDCVSS 3.19.8read 2026-10-23
- NVDCVSS 2.07.5read 2026-10-23
- CISA-ADPweakness (CWE)CWE-9172025-02-04
- NVDweakness (CWE)CWE-917read 2026-10-23
- FIRST EPSSEPSS score99.9 %read 2026-11-02
- PoC-in-GitHubproof of concept20read 2026-11-02
- Exploit-DBdetectionread 2026-11-02
- ProjectDiscoverydetectionread 2026-11-02
- Metasploit FrameworkMetasploit modules1known since 2026-11-01
- GitHub Advisoriesadvisory—
Identifiers
- EUVD-2022-30701same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-653m-wpjp-54c4same flawGitHub Advisory Database · CC-BY-4.0
- exploit/multi/http/atlassian_confluence_namespace_ognl_injectionexploit moduleMetasploit Framework © Rapid7 · BSD-3-Clause
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Published
- 2022-06-03
- Last Modified
- 2026-06-17
- NVD status
- Analyzed
- GitHub Advisory
- GHSA-653m-wpjp-54c4
Frequently asked questions
What is CVE-2022-26134?
Is CVE-2022-26134 actively exploited?
What is the CVSS score for CVE-2022-26134?
Hear about the next vulnerability in your software
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- For a threat intelligence platform: malware, C2 and ransomware indicators over STIX/TAXII.
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CISA KEV · CC0-1.0 (cisagov/kev-data)
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- Exploit-DB · Exploit-DB terms of service · terms restrict redistribution
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GCVE · GCVE dump terms (preserve source attribution)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-653m-wpjp-54c4
- Metasploit Framework · BSD-3-Clause
- Nuclei templates · MIT
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- PoC-in-GitHub · CC0-1.0
- CISA Vulnrichment · CC0-1.0