Skip to main content
ExploitedIn CISA KEVFix available

CVE-2022-24816

Exploitation confirmed. First attested on 2023-10-14 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2022-04-13
  • Fixed in1.1.22
  • WeaknessCWE-94

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

JAI-EXT is an open-source project which aims to extend the Java Advanced Imaging (JAI) API. Programs allowing Jiffle script to be provided via network request can lead to a Remote Code Execution as the Jiffle script is compiled into Java code via Janino, and executed. In particular, this affects the downstream GeoServer project. Version 1.2.22 will contain a patch that disables the ability to inject malicious code into the resulting script. Users unable to upgrade may negate the ability to compile Jiffle scripts from the final application, by removing janino-x.y.z.jar from the classpath.

Timeline

dates in UTC
  1. 2022-04-1321:15CVE publishedNVD
  2. 2023-10-1414:57Listed as exploited by GCVEGCVE
  3. 2023-10-1414:57Exploitation first reportedGCVE
  4. 2024-06-26Added to the CISA KEV catalogCISA KEV
  5. 2024-06-2615:32SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 15:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2022-24816?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2022-24816?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · CISA-ADP · OSV
Geosolutionsgroup jai-ext
BranchAffectedFixed in
1.1< 1.1.221.1.22

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • geosolutions-it jai-ext
    Affected
    • = < 1.1.22no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-04-13

Fix

  1. Update Geosolutionsgroup jai-ext to 1.1.22
  2. CISA’s required action: Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.due 2024-07-17

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
1 repository, unverifiedc1ph3rbyt3/CVE-2022-24816
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2024-06-26
Patch Due Date
2024-07-17
Ransomware Use
Unknown
Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Published
2022-04-13
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-v92f-jx6p-73rx

Frequently asked questions

What is CVE-2022-24816?

JAI-EXT is an open-source project which aims to extend the Java Advanced Imaging (JAI) API. Programs allowing Jiffle script to be provided via network request can lead to a Remote Code Execution as the Jiffle script is compiled into Java code via Janino, and executed. In particular, this affects the downstream GeoServer project. Version 1.2.22 will contain a patch that disables the ability to inject malicious code into the resulting script. Users unable to upgrade may negate the ability to compile Jiffle scripts from the final application, by removing janino-x.y.z.jar from the classpath.

Is CVE-2022-24816 actively exploited?

Yes. CVE-2022-24816 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2024-07-17.

What is the CVSS score for CVE-2022-24816?

CVE-2022-24816 has a CVSS v3 base score of 10 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record