Skip to main content
Public proof of conceptFix available

CVE-2022-24760

A public proof of concept exists; no exploitation attested.

  • Published2022-03-12
  • Fixed in4.10.7
  • WeaknessCWE-1321 · CWE-74

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Parse Server is an open source http web server backend. In versions prior to 4.10.7 there is a Remote Code Execution (RCE) vulnerability in Parse Server. This vulnerability affects Parse Server in the default configuration with MongoDB. The main weakness that leads to RCE is the Prototype Pollution vulnerable code in the file `DatabaseController.js`, so it is likely to affect Postgres and any other database backend as well. This vulnerability has been confirmed on Linux (Ubuntu) and Windows. Users are advised to upgrade as soon as possible. The only known workaround is to manually patch your installation with code referenced at the source GHSA-p6h4-93qp-jhcm.

Timeline

dates in UTC
  1. 2022-03-1200:15CVE publishedNVD

Versions per branch

NVD · OSV
Parseplatform parse-serverversion to verify
BranchAffectedFixed in
4.10< 4.10.74.10.7

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • parse-community parse-server
    Affected
    • = < 4.10.7no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2022-04-16

Fix

  1. Update Parseplatform parse-server to 4.10.7

Advisories and patches

Detection

read 2026-11-01 01:02 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

  • CISA-ADPSSVC decisionpoc2025-04-22
  • CNACVSS 3.110known since 2026-10-23
  • NVDCVSS 3.110read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • CNAweakness (CWE)CWE-74known since 2026-10-23
  • NVDweakness (CWE)CWE-1321read 2026-10-23
  • FIRST EPSSEPSS score49.4 %read 2026-11-04
  • PoC-in-GitHubproof of concept1known since 2026-11-01
  • OSVaffected packages—
  • GitHub AdvisoriesadvisoryCRITICAL2022-03-11

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Published
2022-03-12
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-p6h4-93qp-jhcm

Frequently asked questions

What is CVE-2022-24760?

Parse Server is an open source http web server backend. In versions prior to 4.10.7 there is a Remote Code Execution (RCE) vulnerability in Parse Server. This vulnerability affects Parse Server in the default configuration with MongoDB. The main weakness that leads to RCE is the Prototype Pollution vulnerable code in the file `DatabaseController.js`, so it is likely to affect Postgres and any other database backend as well. This vulnerability has been confirmed on Linux (Ubuntu) and Windows. Users are advised to upgrade as soon as possible. The only known workaround is to manually patch your installation with code referenced at the source GHSA-p6h4-93qp-jhcm.

Is CVE-2022-24760 actively exploited?

A proof-of-concept exploit exists for CVE-2022-24760, but active exploitation has not been confirmed at this time.

What is the CVSS score for CVE-2022-24760?

CVE-2022-24760 has a CVSS v3 base score of 10 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H.

Running parse? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record