Skip to main content
ExploitedNot in CISA KEV yet

CVE-2021-4374

Exploitation confirmed. First attested on 2026-03-09 by GCVE · kevintel, GCVE · shadowserver.

  • Published2023-06-07
  • WeaknessCWE-862

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the process_form.php file. This makes it possible for unauthenticated attackers to arbitrarily update the settings of a vulnerable site and ultimately compromise the entire site.

Timeline

dates in UTC
  1. 2023-06-0702:15CVE publishedNVD
  2. 2026-03-0915:36Listed as exploited by GCVEGCVE
  3. 2026-03-0915:36Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-4374?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-4374?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Valvepress wordpress automatic plugin
BranchAffectedFixed in
3.53≤ 3.53.2no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As Wordfence, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • ValvePress WordPress Automatic Pluginother versions: not affected
    Affected
    • < 3.53.3fixed in 3.53.3semver

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-04-08

Fix

No fix published by the sources we read yet. NVD record

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleauxiliary/admin/http/wp_automatic_plugin_privescrank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-06-07
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-crwv-q9pj-pwrg

Frequently asked questions

What is CVE-2021-4374?

The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the process_form.php file. This makes it possible for unauthenticated attackers to arbitrarily update the settings of a vulnerable site and ultimately compromise the entire site.

Is CVE-2021-4374 actively exploited?

Active exploitation of CVE-2021-4374 has not been confirmed. Its EPSS score was 16.4% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2021-4374?

CVE-2021-4374 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record