CVE-2021-39275
No exploitation reported by the sources we read.
- Published2021-09-16
- Fixed in2.4.49
- WeaknessCWE-787
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
ap_escape_quotes() may write beyond the end of a buffer when given malicious input. No included modules pass untrusted data to these functions, but third-party / external modules may. This issue affects Apache HTTP Server 2.4.48 and earlier.
Timeline
dates in UTC- 2021-09-1615:15CVE publishedNVD
- 2026-10-2319:23EPSS crossed 10 %FIRST EPSS
Observed activity
isMalicious corpus · updated 2026-11-04 09:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-39275?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-39275?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD · OSV| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 2.4 | < 2.4.49 | 2.4.49 | NVD · OSV |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 9.0 | = 9.0 | no fix published | NVD |
| 10.0 | = 10.0 | no fix published | NVD |
| 11.0 | = 11.0 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 17.1 | = 17.1 | no fix published | NVD |
| 17.2 | = 17.2 | no fix published | NVD |
| 17.3 | = 17.3 | no fix published | NVD |
8 more products in the sources.
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- apacheMageia:8all versions · fixed in 2.4.49-1.mga8
- apache2Ubuntu:Pro:16.04:LTSall versions · fixed in 2.4.18-2ubuntu3.17+esm2
- apache2Ubuntu:Pro:14.04:LTSall versions · fixed in 2.4.7-1ubuntu4.22+esm2
- apache2Ubuntu:20.04:LTSall versions · fixed in 2.4.41-4ubuntu3.5
- apache2Ubuntu:18.04:LTSall versions · fixed in 2.4.29-1ubuntu4.17
- apache2TuxCare:Ubuntu:16.04all versions · fixed in 2.4.18-2ubuntu3.19and 7 other packages
- apache2SUSE:OpenStack Cloud Crowbar 9all versions · fixed in 2.4.23-29.80.1
- apache2SUSE:OpenStack Cloud Crowbar 8all versions · fixed in 2.4.23-29.80.1
89 more package ranges on OSV.dev
Vendor advisories
Red Hat Security Advisory: Red Hat JBoss Core Services Apache HTTP Server 2.4.51 security update
Red Hat Security Advisory: Red Hat JBoss Core Services Apache HTTP Server 2.4.51 security update
Red Hat Security Advisory: httpd24-httpd security and bug fix update
Fix
- Update Apache HTTP Server to 2.4.49
- Vendor fix Red Hat Product Security RHSA-2022:7143 · 27 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 Applications using the APR libraries, such as httpd, must be restarted for this update to take effect. After installing the updated packages, the http…
- Vendor fix Red Hat Product Security RHSA-2022:7144 · 1 productFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
- Vendor fix Red Hat Product Security RHSA-2022:6753 · 36 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 After installing the updated packages, the httpd daemon will be restarted automatically.
- Workaround from the vendor Red Hat Product Security RHSA-2022:7143 · 156 productsMitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.
Advisories and patches
- httpd.apache.orgRelease Notes · Vendor Advisory
- lists.apache.orgPatch
- lists.apache.orgPatch
- lists.apache.orgPatch
- lists.apache.orgPatch
- www.oracle.comPatch
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- NVDCVSS 3.19.8read 2026-10-23
- NVDCVSS 2.07.5read 2026-10-23
- NVDweakness (CWE)CWE-787read 2026-10-23
- FIRST EPSSEPSS score39.4 %read 2026-11-03
- OSVaffected packages—
Identifiers
- AZL-6486same flawAzure Linux · MIT
- BIT-apache-2021-39275same flawBitnami · Apache-2.0
- EUVD-2021-25637same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- ALSA-2022:0891advisory covering several CVEsAlmaLinux · MIT
- DLA-2776-1advisory covering several CVEsDebian · LicenseRef-unstated
- DSA-4982-1advisory covering several CVEsDebian · LicenseRef-unstated
- MGASA-2021-0439advisory covering several CVEsMageia · LicenseRef-unstated
- OESA-2021-1387advisory covering several CVEsopenEuler · LicenseRef-unstated
- openSUSE-SU-2021:1438-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- openSUSE-SU-2021:3522-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- RHSA-2022:0143advisory covering several CVEsRed Hat · CC-BY-4.0
- RHSA-2022:0891advisory covering several CVEsRed Hat · CC-BY-4.0
- RHSA-2022:6753advisory covering several CVEsRed Hat · CC-BY-4.0
- RHSA-2022:7143advisory covering several CVEsRed Hat · CC-BY-4.0
- RLSA-2022:0891advisory covering several CVEsRocky Linux · BSD-3-Clause
- SUSE-SU-2021:14811-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2021:3299-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2021:3335-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2021:3522-1advisory covering several CVEsSUSE · LicenseRef-unstated
- USN-5090-1advisory covering several CVEsUbuntu
- USN-5090-2advisory covering several CVEsUbuntu
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Published
- 2021-09-16
- Last Modified
- 2026-06-17
- NVD status
- Analyzed
Frequently asked questions
What is CVE-2021-39275?
Is CVE-2021-39275 actively exploited?
What is the CVSS score for CVE-2021-39275?
Running Apache HTTP Server? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- Red Hat Product Security (CSAF and VEX) · CC-BY-4.0