Skip to main content
Public proof of conceptFix available

CVE-2021-28918

A public proof of concept exists; no exploitation attested.

  • Published2021-04-01
  • Fixed in2.0.1 · 1.1.0
  • WeaknessCWE-704

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Improper input validation of octal strings in netmask npm package v1.0.6 and below allows unauthenticated remote attackers to perform indeterminate SSRF, RFI, and LFI attacks on many of the dependent packages. A remote unauthenticated attacker can bypass packages relying on netmask to filter IPs and reach critical VPN or LAN hosts.

Timeline

dates in UTC
  1. 2021-04-0113:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-28918?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-28918?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

OSV · NVD
netmask
BranchAffectedFixed in
2.0< 2.0.12.0.1
1.1< 1.1.01.1.0
Netmask project netmask
BranchAffectedFixed in
1.0≤ 1.0.6no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • netmaskTuxCare:npmfrom 1.0.6-tuxcare.0 · fixed in 1.0.6-tuxcare.1

Vendor advisories

  • CVE-2021-28918 Red Hat Product Security4 known affected

    nodejs-netmask: improper input validation of octal input data

    rhacm2/application-ui-rhel8 as a component of Red Hat Advanced Cluster Management for Kubernetes 2 · rhacm2/console-header-rhel8 as a component of Red Hat Advanced Cluster Management for Kubernetes 2 · rhacm2/grc-ui-rhel8 as a component of Red Hat Advanced Cluster Management for Kubernetes 2 · +1 more

  • RHSA-2021:2461 Red Hat Product Security77 products fixed

    Red Hat Security Advisory: Red Hat Advanced Cluster Management 2.2.4 security and bug fix update

  • RHSA-2021:1499 Red Hat Product Security77 products fixed

    Red Hat Security Advisory: Red Hat Advanced Cluster Management 2.2.3 security and bug fix update

Full record on NVD

Fix

  1. Update netmask to 2.0.1 · 1.1.0
  2. Vendor fix Red Hat Product Security RHSA-2021:2461 · 77 productsBefore applying this update, make sure all previously released errata relevant to your system have been applied. For details on how to apply this update, refer to: https://access.redhat.com/documentation/en-us/red_hat_advanced_cluster_management_for_kubernetes/2.2/html-single/install/index#instal…
  3. No fix available, says the vendor Red Hat Product Security CVE-2021-28918 · 1 productFix deferred
  4. No fix available, says the vendor Red Hat Product Security CVE-2021-28918 · 3 productsAffected

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Published
2021-04-01
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2021-28918?

Improper input validation of octal strings in netmask npm package v1.0.6 and below allows unauthenticated remote attackers to perform indeterminate SSRF, RFI, and LFI attacks on many of the dependent packages. A remote unauthenticated attacker can bypass packages relying on netmask to filter IPs and reach critical VPN or LAN hosts.

Is CVE-2021-28918 actively exploited?

Active exploitation of CVE-2021-28918 has not been confirmed. Its EPSS score was 15.0% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2021-28918?

CVE-2021-28918 has a CVSS v3 base score of 9.1 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N.

Running netmask? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record