Skip to main content
Exploitation reportedNot in CISA KEV yetFix available

CVE-2021-25032

Exploitation reported by one source. First attested on 2026-10-18 by GCVE · shadowserver.

  • Published2022-01-10
  • Fixed in2.3.1
  • WeaknessCWE-352 · CWE-862

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The PublishPress Capabilities WordPress plugin before 2.3.1, PublishPress Capabilities Pro WordPress plugin before 2.3.1 does not have authorisation and CSRF checks when updating the plugin's settings via the init hook, and does not ensure that the options to be updated belong to the plugin. As a result, unauthenticated attackers could update arbitrary blog options, such as the default role and make any new registered user with an administrator role.

Timeline

dates in UTC
  1. 2022-01-1016:15CVE publishedNVD
  2. 2026-10-1813:50Listed as exploited by GCVEGCVE
  3. 2026-10-1813:50Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-25032?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-25032?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Publishpress capabilities
BranchAffectedFixed in
2.3< 2.3.12.3.1

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Publishpress capabilities to 2.3.1

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
1 repository, unverifiedRandomRobbieBF/CVE-2021-25032
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • GCVEexploitation2026-10-18
  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • CNAweakness (CWE)CWE-352, CWE-862known since 2026-10-23
  • NVDweakness (CWE)CWE-352, CWE-862read 2026-10-23
  • FIRST EPSSEPSS score7.1 %2026-11-03
  • PoC-in-GitHubproof of concept1read 2026-11-03
  • ProjectDiscoverydetectionread 2026-11-03

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2022-01-10
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2021-25032?

The PublishPress Capabilities WordPress plugin before 2.3.1, PublishPress Capabilities Pro WordPress plugin before 2.3.1 does not have authorisation and CSRF checks when updating the plugin's settings via the init hook, and does not ensure that the options to be updated belong to the plugin. As a result, unauthenticated attackers could update arbitrary blog options, such as the default role and make any new registered user with an administrator role.

Is CVE-2021-25032 actively exploited?

Active exploitation of CVE-2021-25032 has not been confirmed. Its EPSS score was 7.1% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2021-25032?

CVE-2021-25032 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record