Skip to main content
Public proof of conceptFix available

CVE-2021-24917

A public proof of concept exists; no exploitation attested.

  • Published2021-12-06
  • Fixed in1.9.1
  • WeaknessCWE-863

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The WPS Hide Login WordPress plugin before 1.9.1 has a bug which allows to get the secret login page by setting a random referer string and making a request to /wp-admin/options.php as an unauthenticated user.

Timeline

dates in UTC
  1. 2021-12-0616:15CVE publishedNVD

Versions per branch

NVD
Wpserveur wps hide login
BranchAffectedFixed in
1.9< 1.9.11.9.1

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Wpserveur wps hide login to 1.9.1

Detection

read 2026-11-01 01:02 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
1 moduleauxiliary/scanner/http/wp_wps_hide_login_revealerrank: normalModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Published
2021-12-06
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2021-24917?

The WPS Hide Login WordPress plugin before 1.9.1 has a bug which allows to get the secret login page by setting a random referer string and making a request to /wp-admin/options.php as an unauthenticated user.

Is CVE-2021-24917 actively exploited?

Active exploitation of CVE-2021-24917 has not been confirmed. Its EPSS score was 72.2% on 2026-11-04, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2021-24917?

CVE-2021-24917 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record