Skip to main content
ExploitedNot in CISA KEV yetFix available

CVE-2021-24442

Exploitation confirmed. First attested on 2025-06-06 by GCVE · kevintel, GCVE · shadowserver.

  • Published2021-07-12
  • Fixed in1.5.3
  • WeaknessCWE-89

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The Poll, Survey, Questionnaire and Voting system WordPress plugin before 1.5.3 did not sanitise, escape or validate the date_answers[] POST parameter before using it in a SQL statement when sending a Poll result, allowing unauthenticated users to perform SQL Injection attacks

Timeline

dates in UTC
  1. 2021-07-1220:15CVE publishedNVD
  2. 2025-06-0620:33Listed as exploited by GCVEGCVE
  3. 2025-06-0620:33Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-24442?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-24442?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Wpdevart poll\, survey\, questionnaire and voting system
BranchAffectedFixed in
1.5< 1.5.31.5.3

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Wpdevart poll\, survey\, questionnaire and voting system to 1.5.3

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • GCVEexploitation2025-06-06
  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • CNAweakness (CWE)CWE-89known since 2026-10-23
  • FIRST EPSSEPSS score46.0 %read 2026-11-02
  • ProjectDiscoverydetectionread 2026-11-02

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2021-07-12
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2021-24442?

The Poll, Survey, Questionnaire and Voting system WordPress plugin before 1.5.3 did not sanitise, escape or validate the date_answers[] POST parameter before using it in a SQL statement when sending a Poll result, allowing unauthenticated users to perform SQL Injection attacks

Is CVE-2021-24442 actively exploited?

Active exploitation of CVE-2021-24442 has not been confirmed. Its EPSS score was 46.0% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2021-24442?

CVE-2021-24442 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record