Skip to main content
Public proof of conceptFix available

CVE-2021-24040

A public proof of concept exists; no exploitation attested.

  • Published2021-09-10
  • Fixed in1.1.0
  • WeaknessCWE-502

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.

Timeline

dates in UTC
  1. 2021-09-13Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-24040?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-24040?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Facebook parlai
BranchAffectedFixed in
1.1< 1.1.01.1.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Facebook parlai to 1.1.0

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-50289
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • CNAweakness (CWE)CWE-502known since 2026-10-23
  • NVDweakness (CWE)CWE-502read 2026-10-23
  • FIRST EPSSEPSS score17.4 %read 2026-11-02
  • Exploit-DBdetectionread 2026-11-02
  • OSVaffected packages—
  • GitHub AdvisoriesadvisoryMODERATE2021-09-13

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2021-09-10
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2021-24040?

Due to use of unsafe YAML deserialization logic, an attacker with the ability to modify local YAML configuration files could provide malicious input, resulting in remote code execution or similar risks. This issue affects ParlAI prior to v1.1.0.

Is CVE-2021-24040 actively exploited?

Active exploitation of CVE-2021-24040 has not been confirmed. Its EPSS score was 17.4% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2021-24040?

CVE-2021-24040 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running parlai? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record