Skip to main content
ExploitedIn CISA KEV

CVE-2021-22894

Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2021-05-27
  • WeaknessCWE-119 · CWE-94

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A buffer overflow vulnerability exists in Pulse Connect Secure before 9.1R11.4 allows a remote authenticated attacker to execute arbitrary code as the root user via maliciously crafted meeting room.

Timeline

dates in UTC
  1. 2021-05-2712:15CVE publishedNVD
  2. 2021-11-03Added to the CISA KEV catalogCISA KEV
  3. 2021-11-03Listed as exploited by GCVEGCVE
  4. 2021-11-03Exploitation first reportedCISA KEV
  5. 2025-02-0415:38SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-22894?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-22894?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Ivanti Connect Secure
BranchAffectedFixed in
9.0= 9.0no fix published
9.1= 9.1no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As hackerone, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Pulse Connect Secure
    Affected
    • = Fixed version 9.1R11.4no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2021-05-27

Fix

  1. CISA’s required action: Apply updates per vendor instructions.due 2022-05-03

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2021-11-03
Patch Due Date
2022-05-03
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2021-05-27
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-2f6h-jr2m-2vpj

Frequently asked questions

What is CVE-2021-22894?

A buffer overflow vulnerability exists in Pulse Connect Secure before 9.1R11.4 allows a remote authenticated attacker to execute arbitrary code as the root user via maliciously crafted meeting room.

Is CVE-2021-22894 actively exploited?

Yes. CVE-2021-22894 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-05-03.

What is the CVSS score for CVE-2021-22894?

CVE-2021-22894 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record