Skip to main content
ExploitedIn CISA KEVFix available

CVE-2021-21311

Exploitation confirmed. First attested on 2025-09-27 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2021-02-11
  • Fixed in4.7.9
  • WeaknessCWE-918

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

Timeline

dates in UTC
  1. 2021-02-1121:15CVE publishedNVD
  2. 2025-09-2703:55Exploitation first reportedCISA-ADP
  3. 2025-09-2703:55SSVC exploitation set to activeCISA-ADP
  4. 2025-09-29Added to the CISA KEV catalogCISA KEV
  5. 2025-09-29Listed as exploited by GCVEGCVE

Versions per branch

NVD · OSV
Adminer
BranchAffectedFixed in
4.x≥ 4.0.0, < 4.7.94.7.9
4.7< 4.7.94.7.9
Debian debian linux
BranchAffectedFixed in
9.0= 9.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As GitHub_M, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • vrana adminer
    Affected
    • = >= 4.0.0, < 4.7.9no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2021-03-02

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • adminerUbuntu:Pro:20.04:LTSall versions · fixed in 4.7.6-1ubuntu0.1~esm1
  • adminerUbuntu:Pro:18.04:LTSall versions · fixed in 4.6.2-1ubuntu0.1~esm1
  • adminerUbuntu:Pro:16.04:LTSall versions · fixed in 4.2.1-1ubuntu1+esm1
  • adminerDebian:14all versions · fixed in 4.7.9-1
  • adminerDebian:13all versions · fixed in 4.7.9-1
  • adminerDebian:12all versions · fixed in 4.7.9-1
  • adminerDebian:9all versions · fixed in 4.2.5-3+deb9u2

Full record on NVD

Fix

  1. Update Adminer to 4.7.9
  2. CISA’s required action: Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.due 2025-10-20

Advisories and patches

Detection

read 2026-11-01 01:02 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2025-09-29
Patch Due Date
2025-10-20
Ransomware Use
Unknown
Required Action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Published
2021-02-11
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-x5r2-hj5c-8jx6

Frequently asked questions

What is CVE-2021-21311?

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

Is CVE-2021-21311 actively exploited?

Yes. CVE-2021-21311 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2025-10-20.

What is the CVSS score for CVE-2021-21311?

CVE-2021-21311 has a CVSS v3 base score of 7.2 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N.

Running vrana/adminer? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record