CVE-2021-21220
Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel.
- Published2021-04-26
- WeaknessCWE-787
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
Insufficient validation of untrusted input in V8 in Google Chrome prior to 89.0.4389.128 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
Timeline
dates in UTCObserved activity
isMalicious corpus · updated 2026-11-03 15:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2021-21220?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2021-21220?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 32.x | = 32 | no fix published | NVD |
| 33.x | = 33 | no fix published | NVD |
| 34.x | = 34 | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 89.0 | < 89.0.4389.128 | 89.0.4389.128 | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA1 product
As Chrome, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- Google ChromeAffected
- < 89.0.4389.128fixed in 89.0.4389.128custom
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2023-12-14
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- chromiumSUSE:Package Hub 15 SP2all versions · fixed in 89.0.4389.128-bp152.2.71.1
- chromiumopenSUSE:Tumbleweedall versions · fixed in 93.0.4577.82-1.1
- chromiumopenSUSE:Tumbleweedall versions · fixed in 113.0.5672.92-1.1
- chromiumopenSUSE:Leap 15.2all versions · fixed in 89.0.4389.128-lp152.2.86.1
- chromiumDebian:14all versions · fixed in 90.0.4430.72-1
- chromiumDebian:13all versions · fixed in 90.0.4430.72-1
- chromiumDebian:12all versions · fixed in 90.0.4430.72-1
- chromiumCleanStartall versions · fixed in 89.0.4389.128-r0
25 more package ranges on OSV.dev
Vendor advisories
- CVE-2021-21220 Red Hat Product Security
chromium-browser: Insufficient validation of untrusted input in V8 for x86_64
Fix
- CISA’s required action: Apply updates per vendor instructions.due 2021-11-17
Advisories and patches
- chromereleases.googleblog.comRelease Notes
- lists.fedoraproject.orgRelease Notes
- lists.fedoraproject.orgRelease Notes
- lists.fedoraproject.orgRelease Notes
Detection
read 2026-11-02 22:42 UTC- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- 4 repositories, unverifiedAmesianX/CVE-2021-21220JacobTaylor3/CVE-2021-21220JacobTaylor3/C2-and-Post-Exploitation-Frameworkborahll/CVE-2021-21220 PoC-in-GitHub
- Metasploit modules
- 1 moduleexploit/multi/browser/chrome_cve_2021_21220_v8_insufficient_validationrank: manualModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause. Metasploit Framework
CISA Known Exploited Vulnerability
- Date Added
- 2021-11-03
- Patch Due Date
- 2021-11-17
- Ransomware Use
- Unknown
- Required Action
- Apply updates per vendor instructions.
Sources
- CISA KEVKEV entry2021-11-03
- ENISA EUVDexploitation2021-11-032021-11-03
- GCVEexploitation2021-11-03
- CISA-ADPSSVC decisionactive2024-02-05
- OpenCVESSVC decisionactive—
- CISA-ADPCVSS 3.18.82025-02-03
- NVDCVSS 3.18.8read 2026-10-23
- NVDCVSS 2.06.8read 2026-10-23
- CISA-ADPweakness (CWE)CWE-7872025-02-03
- NVDweakness (CWE)CWE-787read 2026-10-23
- FIRST EPSSEPSS score70.4 %read 2026-11-02
- PoC-in-GitHubproof of concept4read 2026-11-02
- Metasploit FrameworkMetasploit modules1known since 2026-11-01
- OSVaffected packages—
- GitHub Advisoriesadvisory—
Identifiers
- EUVD-2021-8611same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-5cw9-vvr5-jcwfsame flawGitHub Advisory Database · CC-BY-4.0
- exploit/multi/browser/chrome_cve_2021_21220_v8_insufficient_validationexploit moduleMetasploit Framework © Rapid7 · BSD-3-Clause
- openSUSE-SU-2021:0567-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- openSUSE-SU-2021:0575-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- openSUSE-SU-2021:0712-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- openSUSE-SU-2024:10681-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
- openSUSE-SU-2024:12948-1advisory covering several CVEsopenSUSE · LicenseRef-unstated
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Published
- 2021-04-26
- Last Modified
- 2026-06-17
- NVD status
- Analyzed
- GitHub Advisory
- GHSA-5cw9-vvr5-jcwf
Frequently asked questions
What is CVE-2021-21220?
Is CVE-2021-21220 actively exploited?
What is the CVSS score for CVE-2021-21220?
Running chromium-browser? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- For a threat intelligence platform: malware, C2 and ransomware indicators over STIX/TAXII.
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CISA KEV · CC0-1.0 (cisagov/kev-data)
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GCVE · GCVE dump terms (preserve source attribution)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-5cw9-vvr5-jcwf
- Metasploit Framework · BSD-3-Clause
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- PoC-in-GitHub · CC0-1.0
- Red Hat Product Security (CSAF and VEX) · CC-BY-4.0
- CISA Vulnrichment · CC0-1.0