Skip to main content
Public proof of conceptFix available

CVE-2020-36708

A public proof of concept exists; no exploitation attested.

  • Published2023-06-07
  • Fixed in1.4.2
  • WeaknessCWE-94

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The following themes for WordPress are vulnerable to Function Injections in versions up to and including Shapely <= 1.2.7, NewsMag <= 2.4.1, Activello <= 1.4.0, Illdy <= 2.1.4, Allegiant <= 1.2.2, Newspaper X <= 1.3.1, Pixova Lite <= 2.0.5, Brilliance <= 1.2.7, MedZone Lite <= 1.2.4, Regina Lite <= 2.0.4, Transcend <= 1.1.8, Affluent <= 1.1.0, Bonkers <= 1.0.4, Antreas <= 1.0.2, Sparkling <= 2.4.8, and NatureMag Lite <= 1.0.4. This is due to epsilon_framework_ajax_action. This makes it possible for unauthenticated attackers to call functions and achieve remote code execution.

Timeline

dates in UTC
  1. 2023-06-0702:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-36708?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-36708?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Colorlib activello
BranchAffectedFixed in
1.4< 1.4.21.4.2
Colorlib bonkers
BranchAffectedFixed in
1.0< 1.0.61.0.6
Colorlib illdy
BranchAffectedFixed in
2.1< 2.1.72.1.7

13 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA16 products

As Wordfence, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • machothemes Antreasother versions: not affected
    Affected
    • ≤ 1.0.2no fix statedsemver
  • machothemes NatureMag Liteother versions: not affected
    Affected
    • ≤ 1.0.4no fix statedsemver
  • silkalns Bonkersother versions: not affected
    Affected
    • ≤ 1.0.4no fix statedsemver
  • wpchill Affluentother versions: not affected
    Affected
    • ≤ 1.1.0no fix statedsemver
  • wpchill Transcendother versions: not affected
    Affected
    • ≤ 1.1.8no fix statedsemver
  • wpchill Allegiantother versions: not affected
    Affected
    • ≤ 1.2.2no fix statedsemver

10 more products in the CVE record.

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2026-04-08

Fix

  1. Update Colorlib activello to 1.4.2

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
1 repository, unverifiedb1g-b33f/CVE-2020-36708
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2023-06-07
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-48h4-c5mw-4h8j

Frequently asked questions

What is CVE-2020-36708?

The following themes for WordPress are vulnerable to Function Injections in versions up to and including Shapely <= 1.2.7, NewsMag <= 2.4.1, Activello <= 1.4.0, Illdy <= 2.1.4, Allegiant <= 1.2.2, Newspaper X <= 1.3.1, Pixova Lite <= 2.0.5, Brilliance <= 1.2.7, MedZone Lite <= 1.2.4, Regina Lite <= 2.0.4, Transcend <= 1.1.8, Affluent <= 1.1.0, Bonkers <= 1.0.4, Antreas <= 1.0.2, Sparkling <= 2.4.8, and NatureMag Lite <= 1.0.4. This is due to epsilon_framework_ajax_action. This makes it possible for unauthenticated attackers to call functions and achieve remote code execution.

Is CVE-2020-36708 actively exploited?

Active exploitation of CVE-2020-36708 has not been confirmed. Its EPSS score was 65.3% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-36708?

CVE-2020-36708 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record