Skip to main content
ExploitedIn CISA KEVFix available

CVE-2020-3580

Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2020-10-21
  • Fixed in9.15.1.15 · 9.14.2.8 · 9.13.1.21 · 9.12.4.13 · 9.9.2.85 · 9.8.4.34
  • WeaknessCWE-79

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Multiple vulnerabilities in the web services interface of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to conduct cross-site scripting (XSS) attacks against a user of the web services interface of an affected device. The vulnerabilities are due to insufficient validation of user-supplied input by the web services interface of an affected device. An attacker could exploit these vulnerabilities by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the interface or allow the attacker to access sensitive, browser-based information. Note: These vulnerabilities affect only specific AnyConnect and WebVPN configurations. For more information, see the Vulnerable Products section.

Timeline

dates in UTC
  1. 2020-10-2119:15CVE publishedNVD
  2. 2021-11-03Added to the CISA KEV catalogCISA KEV
  3. 2021-11-03Listed as exploited by GCVEGCVE
  4. 2021-11-03Exploitation first reportedCISA KEV
  5. 2024-11-0816:07SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-3580?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-3580?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Cisco ASA
BranchAffectedFixed in
9.15≥ 9.15, < 9.15.1.159.15.1.15
9.14≥ 9.14, < 9.14.2.89.14.2.8
9.13≥ 9.13, < 9.13.1.219.13.1.21
9.x≥ 9.10, < 9.12.4.139.12.4.13
9.9≥ 9.9, < 9.9.2.859.9.2.85
9.8< 9.8.4.349.8.4.34
Cisco secure firewall threat defense
BranchAffectedFixed in
6.7≥ 6.7.0, < 6.7.0.26.7.0.2
6.x≥ 6.5.0, < 6.6.46.6.4
6.4< 6.4.0.126.4.0.12

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As cisco, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Cisco Adaptive Security Appliance (ASA) Software

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2020-10-21

Fix

  1. Update Cisco ASA to 9.15.1.15 · 9.14.2.8 · 9.13.1.21 · 9.12.4.13 · 9.9.2.85 · 9.8.4.34
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-05-03

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
4 repositories, unverifiedHudi233/CVE-2020-3580adarshvs/CVE-2020-3580cruxN3T/CVE-2020-3580catatonicprime/CVE-2020-3580
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2021-11-03
Patch Due Date
2022-05-03
Ransomware Use
Known
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Published
2020-10-21
Last Modified
2026-08-11
NVD status
Analyzed
GitHub Advisory
GHSA-rr9h-g433-576p

Frequently asked questions

What is CVE-2020-3580?

Multiple vulnerabilities in the web services interface of Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to conduct cross-site scripting (XSS) attacks against a user of the web services interface of an affected device. The vulnerabilities are due to insufficient validation of user-supplied input by the web services interface of an affected device. An attacker could exploit these vulnerabilities by persuading a user of the interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the interface or allow the attacker to access sensitive, browser-based information. Note: These vulnerabilities affect only specific AnyConnect and WebVPN configurations. For more information, see the Vulnerable Products section.

Is CVE-2020-3580 actively exploited?

Yes. CVE-2020-3580 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-05-03.

What is the CVSS score for CVE-2020-3580?

CVE-2020-3580 has a CVSS v3 base score of 6.1 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record