Skip to main content
No exploitation reportedFix available

CVE-2020-27388

No exploitation reported by the sources we read.

  • Published2020-10-23
  • Fixed in1.8
  • WeaknessCWE-79

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. An authenticated user must modify a PHP plugin with a malicious payload and upload it, resulting in multiple stored XSS issues.

Timeline

dates in UTC
  1. 2020-10-2320:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-27388?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-27388?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

OSV · NVD
yourls/yourls
BranchAffectedFixed in
1.x≥ 1.5, < 1.81.8
Yourls
BranchAffectedFixed in
1.x≥ 1.5, ≤ 1.7.10no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update yourls/yourls to 1.8

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.15.4read 2026-10-23
  • NVDCVSS 2.03.5read 2026-10-23
  • NVDweakness (CWE)CWE-79read 2026-10-23
  • FIRST EPSSEPSS score0.7 %2026-11-03
  • OSVaffected packages—
  • GitHub AdvisoriesadvisoryMODERATE2024-01-10

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Published
2020-10-23
Last Modified
2026-07-09
NVD status
Modified
GitHub Advisory
GHSA-pwgg-r6fq-mf94

Frequently asked questions

What is CVE-2020-27388?

Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. An authenticated user must modify a PHP plugin with a malicious payload and upload it, resulting in multiple stored XSS issues.

Is CVE-2020-27388 actively exploited?

Active exploitation of CVE-2020-27388 has not been confirmed. Its EPSS score was 0.7% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-27388?

CVE-2020-27388 has a CVSS v3 base score of 5.4 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N.

Running yourls/yourls? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record