Skip to main content
ExploitedIn CISA KEVFix available

CVE-2020-2506

Exploitation confirmed. First attested on 2022-03-25 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2021-02-03
  • Fixed in3.0.3
  • WeaknessCWE-284

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The vulnerability have been reported to affect earlier versions of QTS. If exploited, this improper access control vulnerability could allow attackers to compromise the security of the software by gaining privileges, or reading sensitive information. This issue affects: QNAP Systems Inc. Helpdesk versions prior to 3.0.3.

Timeline

dates in UTC
  1. 2021-02-0316:15CVE publishedNVD
  2. 2022-03-25Added to the CISA KEV catalogCISA KEV
  3. 2022-03-25Listed as exploited by GCVEGCVE
  4. 2022-03-25Exploitation first reportedCISA KEV
  5. 2025-02-0620:39SSVC exploitation set to activeCISA-ADP

Versions per branch

NVD
Qnap helpdesk
BranchAffectedFixed in
3.0< 3.0.33.0.3

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As qnap, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • QNAP Systems Inc. Helpdesk
    Affected
    • < 3.0.3fixed in 3.0.3custom

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2021-03-11

Fix

  1. Update Qnap helpdesk to 3.0.3
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-04-15

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-03-25
Patch Due Date
2022-04-15
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2021-02-03
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-vph4-5mf4-28v5

Frequently asked questions

What is CVE-2020-2506?

The vulnerability have been reported to affect earlier versions of QTS. If exploited, this improper access control vulnerability could allow attackers to compromise the security of the software by gaining privileges, or reading sensitive information. This issue affects: QNAP Systems Inc. Helpdesk versions prior to 3.0.3.

Is CVE-2020-2506 actively exploited?

Yes. CVE-2020-2506 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-04-15.

What is the CVSS score for CVE-2020-2506?

CVE-2020-2506 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record