Skip to main content
Public proof of conceptFix available

CVE-2020-24972

A public proof of concept exists; no exploitation attested.

  • Published2020-08-29
  • WeaknessCWE-116

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The Kleopatra component before 3.1.12 (and before 20.07.80) for GnuPG allows remote attackers to execute arbitrary code because openpgp4fpr: URLs are supported without safe handling of command-line options. The Qt platformpluginpath command-line option can be used to load an arbitrary DLL.

Timeline

dates in UTC
  1. 2020-08-2921:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-24972?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-24972?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Fedoraproject fedora
BranchAffectedFixed in
32.x= 32no fix published
Kleopatra project kleopatra
BranchAffectedFixed in
20.7< 20.07.8020.07.80
Opensuse backports sle
BranchAffectedFixed in
15.0= 15.0no fix published

1 more product in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • kleopatraUbuntu:26.10all versions · no fixed version listed
  • kleopatraUbuntu:26.04:LTSall versions · no fixed version listed
  • kleopatraUbuntu:25.10all versions · no fixed version listed
  • kleopatraUbuntu:24.04:LTSall versions · no fixed version listed
  • kleopatraUbuntu:22.04:LTSall versions · no fixed version listed
  • kleopatraUbuntu:20.04:LTSall versions · no fixed version listed
  • kleopatraUbuntu:18.04:LTSall versions · no fixed version listed
  • kleopatraSUSE:Package Hub 15 SP1all versions · fixed in 18.12.3-bp151.3.3.1

5 more package ranges on OSV.dev

Vendor advisories

  • CVE-2020-24972 Red Hat Product Security

    Kleopatra: allows remote attackers to execute arbitrary code because openpgp4fpr: URLs are supported without safe handling of command-line options

Full record on NVD

Fix

Advisories and patches

Detection

read 2026-11-03 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
1 repository, unverifiedSpiralBL0CK/CVE-2020-24972
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • CNACVSS 3.18.8known since 2026-10-23
  • NVDCVSS 3.18.8read 2026-10-23
  • NVDCVSS 2.06.5read 2026-10-23
  • NVDweakness (CWE)CWE-116read 2026-10-23
  • FIRST EPSSEPSS score4.9 %2026-11-03
  • PoC-in-GitHubproof of concept1read 2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Published
2020-08-29
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2020-24972?

The Kleopatra component before 3.1.12 (and before 20.07.80) for GnuPG allows remote attackers to execute arbitrary code because openpgp4fpr: URLs are supported without safe handling of command-line options. The Qt platformpluginpath command-line option can be used to load an arbitrary DLL.

Is CVE-2020-24972 actively exploited?

Active exploitation of CVE-2020-24972 has not been confirmed. Its EPSS score was 4.9% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-24972?

CVE-2020-24972 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H.

Running Kleopatra? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record