Skip to main content
ExploitedNot in CISA KEV yetFix available

CVE-2020-15227

Exploitation confirmed. First attested on 2023-10-14 by GCVE · kevintel, GCVE · shadowserver.

  • Published2020-10-01
  • Fixed in3.0.6 · 2.4.16 · 2.3.14 · 2.2.10 · 2.1.13 · 2.0.19
  • WeaknessCWE-74 · CWE-94

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Nette versions before 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, 3.0.6 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE. Nette is a PHP/Composer MVC Framework.

Timeline

dates in UTC
  1. 2020-10-0119:15CVE publishedNVD
  2. 2023-10-1415:50Listed as exploited by GCVEGCVE
  3. 2023-10-1415:50Exploitation first reportedGCVE

Versions per branch

NVD · OSV
Nette application
BranchAffectedFixed in
3.0≥ 3.0.0, < 3.0.63.0.6
2.4≥ 2.4.0, < 2.4.162.4.16
2.3≥ 2.3.0, < 2.3.142.3.14
2.2≥ 2.2.0, < 2.2.102.2.10
2.1≥ 2.1.0, < 2.1.132.1.13
2.0≥ 2.0.0, < 2.0.192.0.19
Debian debian linux
BranchAffectedFixed in
9.0= 9.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • php-netteUbuntu:Pro:16.04:LTSall versions · fixed in 2.3.8-1ubuntu1+esm1
  • php-netteUbuntu:18.04:LTSall versions · fixed in 2.4-20160731-1ubuntu0.1
  • php-netteDebian:9all versions · fixed in 2.4-20160731-1+deb9u1

Vendor advisories

  • CVE-2020-15227 Red Hat Product Security

    php-nette: Code injection attack by passing specially formed parameters to URL

Full record on NVD

Fix

  1. Update Nette application to 3.0.6 · 2.4.16 · 2.3.14 · 2.2.10 · 2.1.13 · 2.0.19

Detection

read 2026-11-01 01:02 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof of concept
Metasploit modules
none listed
Metasploit Framework

Sources

  • GCVEexploitation2023-10-14
  • CNACVSS 3.18.7known since 2026-10-23
  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • CNAweakness (CWE)CWE-74known since 2026-10-23
  • NVDweakness (CWE)CWE-94read 2026-10-23
  • FIRST EPSSEPSS score34.4 %read 2026-11-04
  • PoC-in-GitHubproof of concept3known since 2026-11-01
  • ProjectDiscoverydetectionread 2026-11-04
  • OSVaffected packages—
  • GitHub AdvisoriesadvisoryHIGH2020-10-01

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2020-10-01
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-8gv3-3j7f-wg94

Frequently asked questions

What is CVE-2020-15227?

Nette versions before 2.0.19, 2.1.13, 2.2.10, 2.3.14, 2.4.16, 3.0.6 are vulnerable to an code injection attack by passing specially formed parameters to URL that may possibly leading to RCE. Nette is a PHP/Composer MVC Framework.

Is CVE-2020-15227 actively exploited?

Active exploitation of CVE-2020-15227 has not been confirmed. Its EPSS score was 34.4% on 2026-11-04, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2020-15227?

CVE-2020-15227 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running php-nette? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record