CVE-2020-11027
A public proof of concept exists; no exploitation attested.
- Published2020-04-30
- Fixed in5.4.1 · 5.3.3 · 5.2.6 · 5.1.5 · 5.0.9 · 4.9.14
- WeaknessCWE-640 · CWE-672
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
In affected versions of WordPress, a password reset link emailed to a user does not expire upon changing the user password. Access would be needed to the email account of the user by a malicious party for successful execution. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Timeline
dates in UTC- 2023-06-19Exploit-DB entryExploit-DB
Observed activity
isMalicious corpus · updated 2026-11-03 21:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2020-11027?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2020-11027?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
OSV · NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 5.4 | ≥ 5.4.0, < 5.4.1 | 5.4.1 | OSV |
| 5.3 | ≥ 5.3, < 5.3.3 | 5.3.3 | NVD |
| 5.3 | ≥ 5.3.0, < 5.3.3 | 5.3.3 | OSV |
| 5.2 | ≥ 5.2, < 5.2.6 | 5.2.6 | NVD |
| 5.2 | ≥ 5.2.0, < 5.2.6 | 5.2.6 | OSV |
| 5.1 | ≥ 5.1, < 5.1.5 | 5.1.5 | NVD |
| 5.1 | ≥ 5.1.0, < 5.1.5 | 5.1.5 | OSV |
| 5.0 | ≥ 5.0, < 5.0.9 | 5.0.9 | NVD |
| 5.0 | ≥ 5.0.0, < 5.0.9 | 5.0.9 | OSV |
| 4.9 | ≥ 4.9, < 4.9.14 | 4.9.14 | NVD |
| 4.9 | ≥ 4.9.0, < 4.9.14 | 4.9.14 | OSV |
| 4.8 | ≥ 4.8, < 4.8.13 | 4.8.13 | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 8.0 | = 8.0 | no fix published | NVD |
| 9.0 | = 9.0 | no fix published | NVD |
| 10.0 | = 10.0 | no fix published | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- wordpressUbuntu:26.10all versions · no fixed version listed
- wordpressUbuntu:26.04:LTSall versions · no fixed version listed
- wordpressUbuntu:25.10all versions · no fixed version listed
- wordpressUbuntu:24.04:LTSall versions · no fixed version listed
- wordpressUbuntu:22.04:LTSall versions · no fixed version listed
- wordpressUbuntu:20.04:LTSall versions · no fixed version listed
- wordpressUbuntu:18.04:LTSall versions · no fixed version listed
- wordpressUbuntu:16.04:LTSall versions · no fixed version listed
6 more package ranges on OSV.dev
Vendor advisories
- CVE-2020-11027 Red Hat Product Security
wordpress: password reset link does not expire which could resul in credentials disclosure
Fix
- Update WordPress to 5.4.1 · 5.3.3 · 5.2.6 · 5.1.5 · 5.0.9 · 4.9.14 · 4.8.13
Advisories and patches
- wordpress.orgRelease Notes · Vendor Advisory
Detection
read 2026-11-02 22:42 UTC- Nuclei template
- none so far ProjectDiscovery
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- CNACVSS 3.16.1known since 2026-10-23
- NVDCVSS 3.18.1read 2026-10-23
- NVDCVSS 2.05.5read 2026-10-23
- CNAweakness (CWE)CWE-672known since 2026-10-23
- NVDweakness (CWE)CWE-640read 2026-10-23
- FIRST EPSSEPSS score13.6 %read 2026-11-02
- Exploit-DBdetectionread 2026-11-02
- OSVaffected packages—
- GitHub Advisoriesadvisory—
Identifiers
- BIT-wordpress-2020-11027same flawBitnami · Apache-2.0
- BIT-wordpress-multisite-2020-11027same flawBitnami · Apache-2.0
- EUVD-2020-3412same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-ww7v-jg8c-q6jwsame flawGitHub Advisory Database · CC-BY-4.0
- DLA-2208-1advisory covering several CVEsDebian · LicenseRef-unstated
- DSA-4677-1advisory covering several CVEsDebian · LicenseRef-unstated
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Published
- 2020-04-30
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-ww7v-jg8c-q6jw
Frequently asked questions
What is CVE-2020-11027?
Is CVE-2020-11027 actively exploited?
What is the CVSS score for CVE-2020-11027?
Running WordPress? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- Exploit-DB · Exploit-DB terms of service · terms restrict redistribution
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-ww7v-jg8c-q6jw
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- Red Hat Product Security (CSAF and VEX) · CC-BY-4.0