Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-9978

Exploitation confirmed. First attested on 2021-11-03 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2019-03-24
  • Fixed in3.5.3
  • WeaknessCWE-79

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

The social-warfare plugin before 3.5.3 for WordPress has stored XSS via the wp-admin/admin-post.php?swp_debug=load_options swp_url parameter, as exploited in the wild in March 2019. This affects Social Warfare and Social Warfare Pro.

Timeline

dates in UTC
  1. 2019-03-2415:29CVE publishedNVD
  2. 2019-05-03Exploit-DB entryExploit-DB
  3. 2021-11-03Added to the CISA KEV catalogCISA KEV
  4. 2021-11-03Listed as exploited by GCVEGCVE
  5. 2021-11-03Exploitation first reportedCISA KEV
  6. 2025-02-0716:20SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-9978?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-9978?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Warfareplugins social warfare
BranchAffectedFixed in
3.5< 3.5.33.5.3
Warfareplugins social warfare pro
BranchAffectedFixed in
3.5< 3.5.33.5.3

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Warfareplugins social warfare to 3.5.3
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-05-03

Detection

read 2026-11-03 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-46794EDB-52346
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2021-11-03
Patch Due Date
2022-05-03
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Published
2019-03-24
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-gfx2-wv94-38hv

Frequently asked questions

What is CVE-2019-9978?

The social-warfare plugin before 3.5.3 for WordPress has stored XSS via the wp-admin/admin-post.php?swp_debug=load_options swp_url parameter, as exploited in the wild in March 2019. This affects Social Warfare and Social Warfare Pro.

Is CVE-2019-9978 actively exploited?

Yes. CVE-2019-9978 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-05-03.

What is the CVSS score for CVE-2019-9978?

CVE-2019-9978 has a CVSS v3 base score of 6.1 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record