Skip to main content
No exploitation reportedFix available

CVE-2019-9169

No exploitation reported by the sources we read.

  • Published2019-02-26
  • WeaknessCWE-125

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In the GNU C Library (aka glibc or libc6) through 2.29, proceed_next_node in posix/regexec.c has a heap-based buffer over-read via an attempted case-insensitive regular-expression match.

Timeline

dates in UTC
  1. 2019-02-2602:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-9169?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-9169?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Canonical ubuntu linux
BranchAffectedFixed in
16.4= 16.04no fix published
18.4= 18.04no fix published
19.10= 19.10no fix published
Mcafee web gateway
BranchAffectedFixed in
8.x≥ 8.0.0, < 8.1.18.1.1
7.8≥ 7.8.2.0, < 7.8.2.87.8.2.8
7.7≥ 7.7.2.0, < 7.7.2.217.7.2.21
Gnu glibc
BranchAffectedFixed in
2.29≤ 2.29no fix published

3 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • glibcUbuntu:18.04:LTSall versions · fixed in 2.27-3ubuntu1.2
  • glibcUbuntu:16.04:LTSall versions · fixed in 2.23-0ubuntu11.2
  • glibcTuxCare:RHEL:7all versions · fixed in 2.17-326.el7_9.99.tuxcare.els2and 6 other packages
  • glibcTuxCare:RHEL:7all versions · fixed in 2.17-326.el7_9.99.tuxcare.els3and 6 other packages
  • glibcTuxCare:OracleLinux:7all versions · fixed in 2.17-326.0.9.el7_9.3.tuxcare.els1and 6 other packages
  • glibcTuxCare:OracleLinux:6all versions · fixed in 2.12-2.215.el6.tuxcare.els10and 6 other packages
  • glibcTuxCare:CentOS:7all versions · fixed in 2.17-326.el7_9.99.tuxcare.els2and 6 other packages
  • glibcTuxCare:CentOS:7all versions · fixed in 2.17-326.el7_9.99.tuxcare.els3and 6 other packages

32 more package ranges on OSV.dev

Vendor advisories

  • CVE-2019-9169 Red Hat Product Security882 products fixed · 17 known affected

    glibc: regular-expression match via proceed_next_node in posix/regexec.c leads to heap-based buffer over-read

    glibc.src as a component of Red Hat Enterprise Linux 5 · glibc as a component of Red Hat Enterprise Linux 6 · glibc-common as a component of Red Hat Enterprise Linux 6 · +14 more

  • ICSA-23-348-10 CISA5 known affected

    Siemens SIMATIC S7-1500

    SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AB0) · SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AC0) · SIMATIC S7-1500 CPU 1518F-4 PN/DP MFP (6ES7518-4FX00-1AB0) · +2 more

  • SSA-398330 Siemens ProductCERT5 known affected

    SSA-398330: Vulnerabilities in the additional GNU/Linux subsystem of the SIMATIC S7-1500 CPU 1518(F)-4 PN/DP MFP >= V3.1.0 and < V3.1.5

    SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AB0) >= V3.1.0 < V3.1.5 · SIMATIC S7-1500 CPU 1518-4 PN/DP MFP (6ES7518-4AX00-1AC0) >= V3.1.0 < V3.1.5 · SIMATIC S7-1500 CPU 1518F-4 PN/DP MFP (6ES7518-4FX00-1AB0) >= V3.1.0 < V3.1.5 · +2 more

  • RHSA-2021:1585 Red Hat Product Security882 products fixed

    Red Hat Security Advisory: glibc security, bug fix, and enhancement update

Full record on NVD

Fix

  1. Vendor fix CISA ICSA-23-348-10 · 5 productsUpdate to V3.1.5 or later version
  2. Vendor fix Siemens ProductCERT SSA-398330 · 1 productUpdate to V3.1.5 or later version
  3. Vendor fix Red Hat Product Security RHSA-2021:1585 · 882 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 For the update to take effect, all services linked to the glibc library must be restarted, or the system rebooted.
  4. Mitigation from the vendor CISA ICSA-23-348-10 · 5 productsOnly build and run applications from trusted sources.
  5. No fix planned, says the vendor Red Hat Product Security CVE-2019-9169 · 17 productsWill not fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-02-26
Last Modified
2026-10-14
NVD status
Modified
GitHub Advisory
GHSA-mw8g-rgqf-rw5h

Frequently asked questions

What is CVE-2019-9169?

In the GNU C Library (aka glibc or libc6) through 2.29, proceed_next_node in posix/regexec.c has a heap-based buffer over-read via an attempted case-insensitive regular-expression match.

Is CVE-2019-9169 actively exploited?

Active exploitation of CVE-2019-9169 has not been confirmed. Its EPSS score was 4.7% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-9169?

CVE-2019-9169 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running glibc? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record