CVE-2019-9085
No exploitation reported by the sources we read.
- Published2019-06-24
- Fixed in2.3.1
- WeaknessCWE-20
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
Hoteldruid before v2.3.1 allows remote authenticated users to cause a denial of service (invoice-creation outage) via the n_file parameter to visualizza_contratto.php with invalid arguments (any non-numeric value), as demonstrated by the anno=2019&id_transazione=1&numero_contratto=1&n_file=a query string to visualizza_contratto.php.
Timeline
dates in UTC- 2019-06-2418:15CVE publishedNVD
Observed activity
isMalicious corpus · updated 2026-11-03 15:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-9085?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-9085?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 2.3 | < 2.3.1 | 2.3.1 | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- hoteldruidUbuntu:20.04:LTSall versions · fixed in 2.3.2-1
- hoteldruidUbuntu:18.04:LTSall versions · no fixed version listed
- hoteldruidUbuntu:16.04:LTSall versions · no fixed version listed
- hoteldruidDebian:12all versions · fixed in 2.3.2-1
Fix
- Update Digitaldruid hoteldruid to 2.3.1
Advisories and patches
- www.hoteldruid.comVendor Advisory
Detection
- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Proof-of-concept repositories
- none listed PoC-in-GitHub
- Metasploit modules
- none listed Metasploit Framework
Sources
- NVDCVSS 3.06.5read 2026-10-23
- NVDCVSS 2.04read 2026-10-23
- NVDweakness (CWE)CWE-20read 2026-10-23
- FIRST EPSSEPSS score1.9 %2026-11-03
- OSVaffected packages—
Identifiers
- EUVD-2019-18470same flawENISA EUVD · LicenseRef-ENISA-legal-notice
Technical details
- CVSS v3 Vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Published
- 2019-06-24
- Last Modified
- 2026-06-17
- NVD status
- Modified
Frequently asked questions
What is CVE-2019-9085?
Is CVE-2019-9085 actively exploited?
What is the CVSS score for CVE-2019-9085?
Running hoteldruid? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served