Skip to main content
No exploitation reportedFix available

CVE-2019-9023

No exploitation reported by the sources we read.

  • Published2019-02-22
  • Fixed in7.3.1 · 7.2.14 · 7.1.26 · 5.6.40
  • WeaknessCWE-125

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. A number of heap-based buffer over-read instances are present in mbstring regular expression functions when supplied with invalid multibyte data. These occur in ext/mbstring/oniguruma/regcomp.c, ext/mbstring/oniguruma/regexec.c, ext/mbstring/oniguruma/regparse.c, ext/mbstring/oniguruma/enc/unicode.c, and ext/mbstring/oniguruma/src/utf32_be.c when a multibyte regular expression pattern contains invalid multibyte sequences.

Timeline

dates in UTC
  1. 2019-02-2223:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-9023?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-9023?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
PHP
BranchAffectedFixed in
7.3≥ 7.3.0, < 7.3.17.3.1
7.2≥ 7.2.0, < 7.2.147.2.14
7.x≥ 7.0.0, < 7.1.267.1.26
5.6< 5.6.405.6.40
Canonical ubuntu linux
BranchAffectedFixed in
12.4= 12.04no fix published
14.4= 14.04no fix published
16.4= 16.04no fix published
Debian debian linux
BranchAffectedFixed in
9.0= 9.0no fix published

2 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libmemcachedSUSE:Linux Enterprise Software Development Kit 12 SP4all versions · fixed in 1.0.18-3.2.1
  • libmemcachedSUSE:Linux Enterprise Server for SAP Applications 12 SP4all versions · fixed in 1.0.18-3.2.1
  • libmemcachedSUSE:Linux Enterprise Server for SAP Applications 12 SP3all versions · fixed in 1.0.18-3.2.1
  • libmemcachedSUSE:Linux Enterprise Server 12 SP4all versions · fixed in 1.0.18-3.2.1
  • libmemcachedSUSE:Linux Enterprise Server 12 SP3all versions · fixed in 1.0.18-3.2.1
  • libmemcachedSUSE:Linux Enterprise Module for Web and Scripting 12all versions · fixed in 1.0.18-3.2.1
  • libzipRocky Linux:8all versions · fixed in 0:1.5.1-2.module+el8.4.0+413+c9202dda
  • libzipRed Hat:enterprise_linux:8::appstreamall versions · fixed in 0:1.5.1-2.module+el8.1.0+3202+af5476b9and 5 other packages

70 more package ranges on OSV.dev

Vendor advisories

  • CVE-2019-9023 Red Hat Product Security1,125 products fixed · 87 known affected

    php: Heap-based buffer over-read in mbstring regular expression functions

    php.src as a component of Red Hat Enterprise Linux 5 · php as a component of Red Hat Enterprise Linux 6 · php-bcmath as a component of Red Hat Enterprise Linux 6 · +84 more

  • ICSA-26-027-02 CISA1 known affected

    Festo Didactic SE MES PC

    Festo Didactic SE MES PC shipped with Windows 10

  • RHSA-2020:1624 Red Hat Product Security275 products fixed

    Red Hat Security Advisory: php:7.2 security, bug fix, and enhancement update

  • RHSA-2019:3299 Red Hat Product Security425 products fixed

    Red Hat Security Advisory: rh-php72-php security update

  • RHSA-2019:2519 Red Hat Product Security425 products fixed

    Red Hat Security Advisory: rh-php71-php security, bug fix, and enhancement update

Full record on NVD

Fix

  1. Update PHP to 7.3.1 · 7.2.14 · 7.1.26 · 5.6.40
  2. Vendor fix CISA ICSA-26-027-02 · 1 productFesto Didactic has released Factory Control Panel as a replacement for XAMPP on its MES PCs. Contact technical support at services.didactic@festo.com to obtain the current version of Factory Control Panel which includes fixes for these vulnerabilities.
  3. Vendor fix Red Hat Product Security RHSA-2020:1624 · 275 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 After installing the updated packages, the httpd daemon must be restarted for the update to take effect.
  4. No fix available, says the vendor Red Hat Product Security CVE-2019-9023 · 58 productsFix deferred
  5. No fix planned, says the vendor Red Hat Product Security CVE-2019-9023 · 29 productsOut of support scope

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.09.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • NVDweakness (CWE)CWE-125read 2026-10-23
  • FIRST EPSSEPSS score9.3 %2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-02-22
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2019-9023?

An issue was discovered in PHP before 5.6.40, 7.x before 7.1.26, 7.2.x before 7.2.14, and 7.3.x before 7.3.1. A number of heap-based buffer over-read instances are present in mbstring regular expression functions when supplied with invalid multibyte data. These occur in ext/mbstring/oniguruma/regcomp.c, ext/mbstring/oniguruma/regexec.c, ext/mbstring/oniguruma/regparse.c, ext/mbstring/oniguruma/enc/unicode.c, and ext/mbstring/oniguruma/src/utf32_be.c when a multibyte regular expression pattern contains invalid multibyte sequences.

Is CVE-2019-9023 actively exploited?

Active exploitation of CVE-2019-9023 has not been confirmed. Its EPSS score was 9.3% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-9023?

CVE-2019-9023 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running PHP? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record