Skip to main content
Public proof of conceptFix available

CVE-2019-7304

A public proof of concept exists; no exploitation attested.

  • Published2019-04-23
  • WeaknessCWE-863

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Canonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.

Timeline

dates in UTC
  1. 2019-02-13Exploit-DB entryExploit-DB
  2. 2019-04-2316:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-7304?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-7304?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Canonical ubuntu linux
BranchAffectedFixed in
14.4= 14.04no fix published
16.4= 16.04no fix published
18.4= 18.04no fix published
18.10= 18.10no fix published
Canonical snapd
BranchAffectedFixed in
2.37< 2.37.12.37.1

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • snapdUbuntu:18.04:LTSall versions · fixed in 2.34.2+18.04.1
  • snapdUbuntu:16.04:LTSall versions · fixed in 2.34.2ubuntu0.1
  • snapdUbuntu:14.04:LTSall versions · fixed in 2.34.2~14.04.1
  • snapdDebian:14all versions · fixed in 2.37.1-1
  • snapdDebian:13all versions · fixed in 2.37.1-1
  • snapdDebian:12all versions · fixed in 2.37.1-1

Full record on NVD

Fix

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-46361EDB-46362
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-04-23
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-jvm5-cj73-m9qg

Frequently asked questions

What is CVE-2019-7304?

Canonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.

Is CVE-2019-7304 actively exploited?

Active exploitation of CVE-2019-7304 has not been confirmed. Its EPSS score was 60.8% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-7304?

CVE-2019-7304 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running snapd? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record