Skip to main content
Exploitation reportedNot in CISA KEV yetFix available

CVE-2019-6814

Exploitation reported by one source. First attested on 2024-01-13 by GCVE · shadowserver.

  • Published2019-05-22
  • Fixed in2.1.9.7
  • WeaknessCWE-287

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A CWE-287: Improper Authentication vulnerability exists in the NET55XX Encoder with firmware prior to version 2.1.9.7 which could cause impact to confidentiality, integrity, and availability when a remote attacker crafts a malicious request to the encoder webUI.

Timeline

dates in UTC
  1. 2019-05-2220:29CVE publishedNVD
  2. 2019-07-29Exploit-DB entryExploit-DB
  3. 2024-01-1318:51Listed as exploited by GCVEGCVE
  4. 2024-01-1318:51Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-6814?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-6814?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Schneider-electric net5500 firmwareversion to verify
BranchAffectedFixed in
2.1< 2.1.9.72.1.9.7
Schneider-electric net5501 firmwareversion to verify
BranchAffectedFixed in
2.1< 2.1.9.72.1.9.7
Schneider-electric net5501-i firmwareversion to verify
BranchAffectedFixed in
2.1< 2.1.9.72.1.9.7

4 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Fix

  1. Update Schneider-electric net5500 firmware to 2.1.9.7

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-47186
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/unix/http/schneider_electric_net55xx_encoderrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

  • GCVEexploitation2024-01-13
  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • CNAweakness (CWE)CWE-287known since 2026-10-23
  • NVDweakness (CWE)CWE-287read 2026-10-23
  • FIRST EPSSEPSS score36.7 %read 2026-11-02
  • Exploit-DBdetectionread 2026-11-02
  • Metasploit FrameworkMetasploit modules1known since 2026-11-01

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-05-22
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2019-6814?

A CWE-287: Improper Authentication vulnerability exists in the NET55XX Encoder with firmware prior to version 2.1.9.7 which could cause impact to confidentiality, integrity, and availability when a remote attacker crafts a malicious request to the encoder webUI.

Is CVE-2019-6814 actively exploited?

Active exploitation of CVE-2019-6814 has not been confirmed. Its EPSS score was 36.7% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-6814?

CVE-2019-6814 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record