Skip to main content
No exploitation reportedFix available

CVE-2019-5439

No exploitation reported by the sources we read.

  • Published2019-06-13
  • Fixed in3.0.7
  • WeaknessCWE-119 · CWE-120

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A Buffer Overflow in VLC Media Player < 3.0.7 causes a crash which can possibly be further developed into a remote code execution exploit.

Timeline

dates in UTC
  1. 2019-06-1315:38CVE publishedCNA

Versions per branch

NVD
Videolan vlc media player
BranchAffectedFixed in
3.0< 3.0.73.0.7

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As hackerone, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • VLC Media Player
    Affected
    • = Fixed in 3.0.7no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2019-08-26

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libaomSUSE:Package Hub 15all versions · fixed in 1.0.0-bp150.2.1
  • libaomopenSUSE:Leap 15.0all versions · fixed in 1.0.0-lp150.2.1
  • vlcUbuntu:Pro:16.04:LTSall versions · no fixed version listed
  • vlcUbuntu:18.04:LTSall versions · fixed in 3.0.7.1-0ubuntu18.04.1
  • vlcSUSE:Package Hub 15 SP1all versions · fixed in 3.0.7.1-bp151.5.3.3
  • vlcSUSE:Package Hub 15all versions · fixed in 3.0.7.1-bp150.2.6.1
  • vlcopenSUSE:Tumbleweedall versions · fixed in 3.0.16-1.5
  • vlcopenSUSE:Leap 15.1all versions · fixed in 3.0.7.1-lp151.6.3.1

5 more package ranges on OSV.dev

Full record on NVD

Fix

  1. Update Videolan vlc media player to 3.0.7

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

  • CISA-ADPSSVC decisionnone2026-11-02
  • NVDCVSS 3.06.5read 2026-11-02
  • NVDCVSS 2.04.3read 2026-11-02
  • CNAweakness (CWE)CWE-1202019-08-26
  • NVDweakness (CWE)CWE-119read 2026-11-02
  • FIRST EPSSEPSS score5.3 %2026-11-04
  • OSVaffected packages—
  • GitHub Advisoriesadvisory—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Published
2019-06-13
Last Modified
2026-11-02
NVD status
Modified
GitHub Advisory
GHSA-r9hw-7j54-8fpw

Frequently asked questions

What is CVE-2019-5439?

A Buffer Overflow in VLC Media Player < 3.0.7 causes a crash which can possibly be further developed into a remote code execution exploit.

Is CVE-2019-5439 actively exploited?

Active exploitation of CVE-2019-5439 has not been confirmed. Its EPSS score was 5.3% on 2026-11-04, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-5439?

CVE-2019-5439 has a CVSS v3 base score of 6.5 (MEDIUM severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H.

Running vlc? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record