Skip to main content
Public proof of conceptFix available

CVE-2019-19012

A public proof of concept exists; no exploitation attested.

  • Published2019-11-17
  • WeaknessCWE-125 · CWE-190

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An integer overflow in the search_in_range function in regexec.c in Oniguruma 6.x before 6.9.4_rc2 leads to an out-of-bounds read, in which the offset of this read is under the control of an attacker. (This only affects the 32-bit compiled version). Remote attackers can cause a denial-of-service or information disclosure, or possibly have unspecified other impact, via a crafted regular expression.

Timeline

dates in UTC
  1. 2019-11-1718:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-19012?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-19012?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Fedoraproject fedora
BranchAffectedFixed in
30.x= 30no fix published
31.x= 31no fix published
Oniguruma project oniguruma
BranchAffectedFixed in
6.x≥ 6.0.0, ≤ 6.9.3no fix published
6.9= 6.9.4no fix published
Debian debian linux
BranchAffectedFixed in
8.0= 8.0no fix published

1 more product in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libonigUbuntu:Pro:18.04:LTSall versions · fixed in 6.7.0-1ubuntu0.1~esm2
  • libonigUbuntu:Pro:16.04:LTSall versions · fixed in 5.9.6-1ubuntu0.1+esm2
  • libonigUbuntu:Pro:16.04:LTSall versions · fixed in 5.9.6-1ubuntu0.1+esm3
  • libonigUbuntu:Pro:14.04:LTSall versions · fixed in 5.9.1-1ubuntu1.1+esm2
  • libonigUbuntu:Pro:14.04:LTSall versions · fixed in 5.9.1-1ubuntu1.1+esm3
  • libonigDebian:14all versions · fixed in 6.9.4-1
  • libonigDebian:13all versions · fixed in 6.9.4-1
  • libonigDebian:12all versions · fixed in 6.9.4-1

66 more package ranges on OSV.dev

Vendor advisories

  • CVE-2019-19012 Red Hat Product Security270 products fixed · 79 known affected

    oniguruma: integer overflow in search_in_range function in regexec.c leads to out-of-bounds read

    php.src as a component of Red Hat Enterprise Linux 5 · php53.src as a component of Red Hat Enterprise Linux 5 · oniguruma-devel as a component of Red Hat Enterprise Linux 6 · +76 more

  • RHSA-2025:7539 Red Hat Product Security144 products fixed

    Red Hat Security Advisory: ruby:2.5 security update

  • RHSA-2024:0889 Red Hat Product Security31 products fixed

    Red Hat Security Advisory: oniguruma security update

  • RHSA-2024:0572 Red Hat Product Security31 products fixed

    Red Hat Security Advisory: oniguruma security update

  • RHSA-2024:0409 Red Hat Product Security31 products fixed

    Red Hat Security Advisory: oniguruma security update

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2025:7539 · 144 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
  2. No fix planned, says the vendor Red Hat Product Security CVE-2019-19012 · 32 productsOut of support scope
  3. No fix planned, says the vendor Red Hat Product Security CVE-2019-19012 · 47 productsWill not fix

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
2 repositories, unverifiedManhNDd/CVE-2019-19012tarantula-team/CVE-2019-19012
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • NVDweakness (CWE)CWE-125, CWE-190read 2026-10-23
  • FIRST EPSSEPSS score10.6 %read 2026-11-02
  • PoC-in-GitHubproof of concept2read 2026-11-02
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-11-17
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2019-19012?

An integer overflow in the search_in_range function in regexec.c in Oniguruma 6.x before 6.9.4_rc2 leads to an out-of-bounds read, in which the offset of this read is under the control of an attacker. (This only affects the 32-bit compiled version). Remote attackers can cause a denial-of-service or information disclosure, or possibly have unspecified other impact, via a crafted regular expression.

Is CVE-2019-19012 actively exploited?

Active exploitation of CVE-2019-19012 has not been confirmed. Its EPSS score was 10.6% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-19012?

CVE-2019-19012 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running oniguruma? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record