CVE-2019-1821
Exploitation confirmed. First attested on 2023-10-14 by GCVE · kevintel, GCVE · shadowserver.
- Published2019-05-16
- Fixed in3.0.1
- WeaknessCWE-20
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
A vulnerability in the web-based management interface of Cisco Prime Infrastructure (PI) and Cisco Evolved Programmable Network (EPN) Manager could allow an authenticated, remote attacker to execute code with root-level privileges on the underlying operating system. This vulnerability exist because the software improperly validates user-supplied input. An attacker could exploit this vulnerability by uploading a malicious file to the administrative web interface. A successful exploit could allow the attacker to execute code with root-level privileges on the underlying operating system.
Timeline
dates in UTC- 2019-05-1601:29CVE publishedNVD
- 2019-05-17Exploit-DB entryExploit-DB
- 2023-10-1414:56Listed as exploited by GCVEGCVE
- 2023-10-1414:56Exploitation first reportedGCVE
Observed activity
isMalicious corpus · updated 2026-11-04 03:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-1821?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-1821?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 3.0 | < 3.0.1 | 3.0.1 | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 3.0 | = 3.0\(0.0.83b\) | no fix published | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 3.4 | < 3.4.1 | 3.4.1 | NVD |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA1 product
As cisco, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- Cisco Prime InfrastructureAffected
- = 3.4no fix stated
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2019-06-19
Fix
- Update Cisco evolved programmable network manager to 3.0.1
Advisories and patches
- tools.cisco.comVendor Advisory
Detection
read 2026-11-03 22:42 UTC- Nuclei template
- available ProjectDiscovery
- Metasploit modules
- 1 moduleexploit/linux/http/cpi_tararchive_uploadrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause. Metasploit Framework
Sources
- GCVEexploitation2023-10-14
- CISA-ADPSSVC decisionnone2024-11-20
- OpenCVESSVC decisionnone—
- CNACVSS 3.08.8known since 2026-10-23
- NVDCVSS 3.09.8read 2026-10-23
- NVDCVSS 2.010read 2026-10-23
- CNAweakness (CWE)CWE-20known since 2026-10-23
- NVDweakness (CWE)CWE-20read 2026-10-23
- FIRST EPSSEPSS score98.1 %read 2026-11-03
- PoC-in-GitHubproof of concept1read 2026-11-03
- Exploit-DBdetectionread 2026-11-03
- ProjectDiscoverydetectionread 2026-11-03
- Metasploit FrameworkMetasploit modules1known since 2026-11-01
- GitHub Advisoriesadvisory—
Identifiers
- EUVD-2019-10378same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-4mx6-fjqc-4rhrsame flawGitHub Advisory Database · CC-BY-4.0
- exploit/linux/http/cpi_tararchive_uploadexploit moduleMetasploit Framework © Rapid7 · BSD-3-Clause
Technical details
- CVSS v3 Vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Published
- 2019-05-16
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-4mx6-fjqc-4rhr
Frequently asked questions
What is CVE-2019-1821?
Is CVE-2019-1821 actively exploited?
What is the CVSS score for CVE-2019-1821?
Hear about the next vulnerability in your software
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- For a threat intelligence platform: malware, C2 and ransomware indicators over STIX/TAXII.
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- Exploit-DB · Exploit-DB terms of service · terms restrict redistribution
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GCVE · GCVE dump terms (preserve source attribution)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-4mx6-fjqc-4rhr
- Metasploit Framework · BSD-3-Clause
- Nuclei templates · MIT
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- PoC-in-GitHub · CC0-1.0
- CISA Vulnrichment · CC0-1.0