Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-16928

Exploitation confirmed. First attested on 2022-03-03 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2019-09-27
  • WeaknessCWE-787

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846. There is a heap-based buffer overflow in string_vformat in string.c involving a long EHLO command.

Timeline

dates in UTC
  1. 2019-09-2721:15CVE publishedNVD
  2. 2022-03-03Added to the CISA KEV catalogCISA KEV
  3. 2022-03-03Listed as exploited by GCVEGCVE
  4. 2022-03-03Exploitation first reportedCISA KEV
  5. 2025-02-0420:03SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-16928?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-16928?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Exim
BranchAffectedFixed in
4.92≥ 4.92, ≤ 4.92.2no fix published
Fedoraproject fedora
BranchAffectedFixed in
29.x= 29no fix published
30.x= 30no fix published
31.x= 31no fix published
Canonical ubuntu linux
BranchAffectedFixed in
19.4= 19.04no fix published

1 more product in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • eximSUSE:Package Hub 15 SP2all versions · fixed in 4.94.2-bp152.6.4.1
  • eximSUSE:Package Hub 15 SP1all versions · fixed in 4.94.2-bp151.2.4.1
  • eximopenSUSE:Tumbleweedall versions · fixed in 4.94.2-4.2
  • eximopenSUSE:Leap 15.2all versions · fixed in 4.94.2-lp152.8.3.1
  • eximCleanStartall versions · fixed in 4.92.2-r1
  • eximAlpine:v3.24from 4.92 · fixed in 4.92.2-r1
  • eximAlpine:v3.23from 4.92 · fixed in 4.92.2-r1
  • eximAlpine:v3.22from 4.92 · fixed in 4.92.2-r1

19 more package ranges on OSV.dev

Vendor advisories

  • CVE-2019-16928 Red Hat Product Security

    exim: remotely triggerable buffer overflow in string_vformat()

Full record on NVD

Fix

  1. CISA’s required action: Apply updates per vendor instructions.due 2022-03-17

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-03-03
Patch Due Date
2022-03-17
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-09-27
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-xg2f-gj2p-r7xq

Frequently asked questions

What is CVE-2019-16928?

Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than CVE-2019-15846. There is a heap-based buffer overflow in string_vformat in string.c involving a long EHLO command.

Is CVE-2019-16928 actively exploited?

Yes. CVE-2019-16928 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-03-17.

What is the CVSS score for CVE-2019-16928?

CVE-2019-16928 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running Exim? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record