Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-1579

Exploitation confirmed. First attested on 2022-01-10 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2019-07-19
  • Fixed in8.1.3 · 8.0.12 · 7.1.19
  • WeaknessCWE-134

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Remote Code Execution in PAN-OS 7.1.18 and earlier, PAN-OS 8.0.11-h1 and earlier, and PAN-OS 8.1.2 and earlier with GlobalProtect Portal or GlobalProtect Gateway Interface enabled may allow an unauthenticated remote attacker to execute arbitrary code.

Timeline

dates in UTC
  1. 2019-07-1922:15CVE publishedNVD
  2. 2022-01-10Added to the CISA KEV catalogCISA KEV
  3. 2022-01-10Listed as exploited by GCVEGCVE
  4. 2022-01-10Exploitation first reportedCISA KEV
  5. 2026-10-0120:07SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-1579?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-1579?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Palo Alto PAN-OS
BranchAffectedFixed in
8.1≥ 8.1.0, < 8.1.38.1.3
8.0≥ 8.0.0, < 8.0.128.0.12
7.1< 7.1.197.1.19

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As palo_alto, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Palo Alto Networks GlobalProtect Portal/Gateway Interface
    Affected
    • = PAN-OS 7.1.18 and earlier, PAN-OS 8.0.11 and earlier, and PAN-OS 8.1.2 and earlier releasesno fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2020-02-17

Fix

  1. Update Palo Alto PAN-OS to 8.1.3 · 8.0.12 · 7.1.19
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-07-10

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
2 repositories, unverifiedsecurifera/CVE-2019-1579Elsfa7-110/CVE-2019-1579
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-01-10
Patch Due Date
2022-07-10
Ransomware Use
Known
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-07-19
Last Modified
2026-10-02
NVD status
Analyzed
GitHub Advisory
GHSA-3w36-wf5x-rjfv

Frequently asked questions

What is CVE-2019-1579?

Remote Code Execution in PAN-OS 7.1.18 and earlier, PAN-OS 8.0.11-h1 and earlier, and PAN-OS 8.1.2 and earlier with GlobalProtect Portal or GlobalProtect Gateway Interface enabled may allow an unauthenticated remote attacker to execute arbitrary code.

Is CVE-2019-1579 actively exploited?

Yes. CVE-2019-1579 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-07-10.

What is the CVSS score for CVE-2019-1579?

CVE-2019-1579 has a CVSS v3 base score of 8.1 (HIGH severity), with vector string CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H.

Hear about the next vulnerability in your software

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record