Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-15107

Exploitation confirmed. First attested on 2022-03-25 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2019-08-16
  • WeaknessCWE-78

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.

Timeline

dates in UTC
  1. 2019-08-12Exploit-DB entryExploit-DB
  2. 2019-08-1603:15CVE publishedNVD
  3. 2022-03-25Added to the CISA KEV catalogCISA KEV
  4. 2022-03-25Listed as exploited by GCVEGCVE
  5. 2022-03-25Exploitation first reportedCISA KEV
  6. 2026-08-0520:29SSVC exploitation set to activeCISA-ADP

Versions per branch

NVD
Webmin
BranchAffectedFixed in
1.920≤ 1.920no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • webminMageia:7all versions · fixed in 1.930-1.mga7

Full record on NVD

Fix

  1. CISA’s required action: Apply updates per vendor instructions.due 2022-04-15

Advisories and patches

Detection

read 2026-11-01 01:02 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
EDB-47230EDB-47293
Exploit-DB
Metasploit modules
1 moduleexploit/linux/http/webmin_backdoorrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-03-25
Patch Due Date
2022-04-15
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2019-08-16
Last Modified
2026-08-06
NVD status
Analyzed
GitHub Advisory
GHSA-69hp-hrv4-rxrr

Frequently asked questions

What is CVE-2019-15107?

An issue was discovered in Webmin <=1.920. The parameter old in password_change.cgi contains a command injection vulnerability.

Is CVE-2019-15107 actively exploited?

Yes. CVE-2019-15107 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-04-15.

What is the CVSS score for CVE-2019-15107?

CVE-2019-15107 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running webmin? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record