Skip to main content
No exploitation reportedFix available

CVE-2019-14241

No exploitation reported by the sources we read.

  • Published2019-07-23
  • WeaknessCWE-835

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

HAProxy through 2.0.2 allows attackers to cause a denial of service (ha_panic) via vectors related to htx_manage_client_side_cookies in proto_htx.c.

Timeline

dates in UTC
  1. 2019-07-2313:15CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-14241?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-14241?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
HAProxy
BranchAffectedFixed in
1.x≥ 1.4, ≤ 1.9.8no fix published
2.0≥ 2.0.0, ≤ 2.0.2no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • haproxySUSE:Linux Enterprise High Availability Extension 15 SP1all versions · fixed in 2.0.5+git0.d905f49a-8.3.5
  • haproxySUSE:Linux Enterprise High Availability Extension 15all versions · fixed in 2.0.5+git0.d905f49a-3.12.6
  • haproxyopenSUSE:Tumbleweedall versions · fixed in 2.4.4+git0.acb1d0bea-1.2
  • haproxyopenSUSE:Leap 15.1all versions · fixed in 2.0.5+git0.d905f49a-lp151.2.3.1
  • haproxyopenSUSE:Leap 15.0all versions · fixed in 2.0.5+git0.d905f49a-lp150.2.13.1

Vendor advisories

  • CVE-2019-14241 Red Hat Product Security

    haproxy: DoS via vectors realted to htx_manage_client_side_cookies in proto_htx.c

Full record on NVD

Fix

No fix published by the sources we read yet. NVD record

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.07.5read 2026-10-23
  • NVDCVSS 2.05read 2026-10-23
  • NVDweakness (CWE)CWE-835read 2026-10-23
  • FIRST EPSSEPSS score70.2 %read 2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
2019-07-23
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2019-14241?

HAProxy through 2.0.2 allows attackers to cause a denial of service (ha_panic) via vectors related to htx_manage_client_side_cookies in proto_htx.c.

Is CVE-2019-14241 actively exploited?

Active exploitation of CVE-2019-14241 has not been confirmed. Its EPSS score was 70.2% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2019-14241?

CVE-2019-14241 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H.

Running HAProxy? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record