Skip to main content
ExploitedIn CISA KEVFix available

CVE-2019-10758

Exploitation confirmed. First attested on 2021-12-10 by CISA-ADP, CISA KEV, GCVE · kevintel, GCVE · shadowserver.

  • Published2019-12-24
  • Fixed in0.54.0
  • WeaknessCWE-94

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the `toBSON` method. A misuse of the `vm` dependency to perform `exec` commands in a non-safe environment.

Timeline

dates in UTC
  1. 2019-12-2422:15CVE publishedNVD
  2. 2021-12-10Added to the CISA KEV catalogCISA KEV
  3. 2021-12-10Listed as exploited by GCVEGCVE
  4. 2021-12-10Exploitation first reportedCISA KEV
  5. 2025-02-0712:54SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2019-10758?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2019-10758?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD · OSV
Mongo-express project mongo-express
BranchAffectedFixed in
0.54< 0.54.00.54.0

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As snyk, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • mongo-express
    Affected
    • = All versions prior to version 0.54.0no fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2019-12-24

Fix

  1. Update Mongo-express project mongo-express to 0.54.0
  2. CISA’s required action: Apply updates per vendor instructions.due 2022-06-10

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
3 repositories, unverifiedmasahiro331/CVE-2019-10758lp008/CVE-2019-10758CyberCTF/vulhub-mongo-express-cve-2019-10758
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2021-12-10
Patch Due Date
2022-06-10
Ransomware Use
Unknown
Required Action
Apply updates per vendor instructions.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Published
2019-12-24
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-h47j-hc6x-h3qq

Frequently asked questions

What is CVE-2019-10758?

mongo-express before 0.54.0 is vulnerable to Remote Code Execution via endpoints that uses the `toBSON` method. A misuse of the `vm` dependency to perform `exec` commands in a non-safe environment.

Is CVE-2019-10758 actively exploited?

Yes. CVE-2019-10758 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-06-10.

What is the CVSS score for CVE-2019-10758?

CVE-2019-10758 has a CVSS v3 base score of 9.9 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H.

Running mongo-express? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record