Skip to main content
ExploitedIn CISA KEVFix available

CVE-2018-5002

Exploitation confirmed. First attested on 2022-05-23 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2018-07-09
  • WeaknessCWE-121 · CWE-787

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Adobe Flash Player versions 29.0.0.171 and earlier have a Stack-based buffer overflow vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.

Timeline

dates in UTC
  1. 2018-07-0919:29CVE publishedNVD
  2. 2022-05-23Added to the CISA KEV catalogCISA KEV
  3. 2022-05-23Listed as exploited by GCVEGCVE
  4. 2022-05-23Exploitation first reportedCISA KEV
  5. 2025-11-1719:21SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-5002?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-5002?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Adobe flash playerversion to verify
BranchAffectedFixed in
29.0≤ 29.0.0.171no fix published
Adobe flash player desktop runtimeversion to verify
BranchAffectedFixed in
29.0≤ 29.0.0.171no fix published
Redhat enterprise linux desktop
BranchAffectedFixed in
6.0= 6.0no fix published

2 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Products declared by the CNA1 product

As adobe, the CNA that assigned this CVE, declared them in the CVE record; versions as written.

  • Adobe Flash Player 29.0.0.171 and earlier versions
    Affected
    • = Adobe Flash Player 29.0.0.171 and earlier versionsno fix stated

Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2018-10-21

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • flash-player-pluginMageia:6all versions · fixed in 30.0.0.113-1.mga6.nonfree
  • flash-pluginRed Hat:rhel_extras:6all versions · fixed in 0:30.0.0.113-1.el6_9
  • flashplugin-nonfreeUbuntu:18.04:LTSall versions · fixed in 30.0.0.113ubuntu0.18.04.1
  • flashplugin-nonfreeUbuntu:16.04:LTSall versions · fixed in 30.0.0.113ubuntu0.16.04.1
  • flashplugin-nonfreeUbuntu:14.04:LTSall versions · fixed in 30.0.0.113ubuntu0.14.04.1

Vendor advisories

  • CVE-2018-5002 Red Hat Product Security3 products fixed

    flash-plugin: Arbitrary Code Execution vulnerability (APSB18-19)

  • RHSA-2018:1827 Red Hat Product Security3 products fixed

    Red Hat Security Advisory: flash-plugin security update

Full record on NVD

Fix

  1. CISA’s required action: The impacted product is end-of-life and should be disconnected if still in use.due 2022-06-13
  2. Vendor fix Red Hat Product Security RHSA-2018:1827 · 3 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-05-23
Patch Due Date
2022-06-13
Ransomware Use
Unknown
Required Action
The impacted product is end-of-life and should be disconnected if still in use.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Published
2018-07-09
Last Modified
2026-06-17
NVD status
Analyzed
GitHub Advisory
GHSA-3rj8-qvqp-3335

Frequently asked questions

What is CVE-2018-5002?

Adobe Flash Player versions 29.0.0.171 and earlier have a Stack-based buffer overflow vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.

Is CVE-2018-5002 actively exploited?

Yes. CVE-2018-5002 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-06-13.

What is the CVSS score for CVE-2018-5002?

CVE-2018-5002 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H.

Running flash-plugin? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record