Skip to main content
Public proof of conceptFix available

CVE-2018-4162

A public proof of concept exists; no exploitation attested.

  • Published2018-04-03
  • WeaknessCWE-119

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affected. iTunes before 12.7.4 on Windows is affected. tvOS before 11.3 is affected. watchOS before 4.3 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.

Timeline

dates in UTC
  1. 2018-04-0306:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-4162?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-4162?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Canonical ubuntu linux
BranchAffectedFixed in
16.4= 16.04no fix published
17.10= 17.10no fix published
Apple icloudversion to verify
BranchAffectedFixed in
7.4< 7.47.4
Apple iphone os
BranchAffectedFixed in
11.3< 11.311.3

5 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • gtk3openSUSE:Tumbleweedall versions · fixed in 2.32.4-1.1
  • qtwebkit-opensource-srcUbuntu:24.04:LTSall versions · no fixed version listed
  • qtwebkit-opensource-srcUbuntu:22.04:LTSall versions · no fixed version listed
  • qtwebkit-opensource-srcUbuntu:20.04:LTSall versions · no fixed version listed
  • webkit2Mageia:6all versions · fixed in 2.20.1-1.mga6
  • webkit2gtkUbuntu:16.04:LTSall versions · fixed in 2.20.1-0ubuntu0.16.04.1
  • webkit2gtkDebian:14all versions · fixed in 2.20.0-2
  • webkit2gtkDebian:13all versions · fixed in 2.20.0-2

11 more package ranges on OSV.dev

Full record on NVD

Fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/apple_ios/browser/safari_jitrank: goodModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

  • NVDCVSS 3.08.8read 2026-10-23
  • NVDCVSS 2.06.8read 2026-10-23
  • NVDweakness (CWE)CWE-119read 2026-10-23
  • FIRST EPSSEPSS score37.8 %read 2026-11-02
  • Metasploit FrameworkMetasploit modules1known since 2026-11-01
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Published
2018-04-03
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-4162?

An issue was discovered in certain Apple products. iOS before 11.3 is affected. Safari before 11.1 is affected. iCloud before 7.4 on Windows is affected. iTunes before 12.7.4 on Windows is affected. tvOS before 11.3 is affected. watchOS before 4.3 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.

Is CVE-2018-4162 actively exploited?

Active exploitation of CVE-2018-4162 has not been confirmed. Its EPSS score was 37.8% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-4162?

CVE-2018-4162 has a CVSS v3 base score of 8.8 (HIGH severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H.

Running gtk3? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record