Skip to main content
ExploitedNot in CISA KEV yetFix available

CVE-2018-3760

Exploitation confirmed. First attested on 2023-10-14 by GCVE · kevintel, GCVE · shadowserver.

  • Published2018-06-26
  • Fixed in4.0.0.beta8 · 3.7.2 · 2.12.5
  • WeaknessCWE-200 · CWE-22

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

There is an information leak vulnerability in Sprockets. Versions Affected: 4.0.0.beta7 and lower, 3.7.1 and lower, 2.12.4 and lower. Specially crafted requests can be used to access files that exists on the filesystem that is outside an application's root directory, when the Sprockets server is used in production. All users running an affected release should either upgrade or use one of the work arounds immediately.

Timeline

dates in UTC
  1. 2018-06-2619:29CVE publishedNVD
  2. 2023-10-1414:56Listed as exploited by GCVEGCVE
  3. 2023-10-1414:56Exploitation first reportedGCVE

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-3760?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-3760?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

OSV · NVD
sprockets
BranchAffectedFixed in
4.0≥ 4.0.0.beta1, < 4.0.0.beta84.0.0.beta8
3.x≥ 3.0.0, < 3.7.23.7.2
2.12< 2.12.52.12.5
Redhat enterprise linux
BranchAffectedFixed in
6.0= 6.0no fix published
6.7= 6.7no fix published
7.0= 7.0no fix published
7.3= 7.3no fix published
7.4= 7.4no fix published
7.5= 7.5no fix published
7.6= 7.6no fix published
Sprockets project sprockets
BranchAffectedFixed in
2.x≥ 2.0.0, ≤ 2.12.4no fix published
3.x≥ 3.0.0, ≤ 3.7.1no fix published
4.0= 4.0.0no fix published

2 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • ansible-tower-setupRed Hat:cloudforms_managementengine:5.8::el7all versions · fixed in 0:3.1.8-1.el7atand 1 other package
  • cfmeRed Hat:cloudforms_managementengine:5.9::el7all versions · fixed in 0:5.9.4.7-1.el7cfand 8 other packages
  • cfmeRed Hat:cloudforms_managementengine:5.8::el7all versions · fixed in 0:5.8.5.1-1.el7cfand 4 other packages
  • crowbarSUSE:OpenStack Cloud Crowbar 8all versions · fixed in 5.0+git.1528696845.81a7b5d0-3.3.1
  • crowbarSUSE:OpenStack Cloud 7all versions · fixed in 4.0+git.1528801103.f5708341-7.20.1
  • crowbarSUSE:Enterprise Storage 4all versions · fixed in 4.0+git.1528801103.f5708341-7.20.1
  • crowbar-coreSUSE:OpenStack Cloud Crowbar 8all versions · fixed in 5.0+git.1533887407.6e9b0412d-3.8.2
  • crowbar-coreSUSE:OpenStack Cloud 7all versions · fixed in 4.0+git.1534246408.3ab19c567-9.33.1

34 more package ranges on OSV.dev

Vendor advisories

  • CVE-2018-3760 Red Hat Product Security80 products fixed · 2 known affected

    rubygem-sprockets: Path traversal in forbidden_request?() can allow remote attackers to read arbitrary files

    ruby193-rubygem-sprockets.src as a component of Red Hat Ceph Storage 1.3 · ruby193-rubygem-sprockets.src as a component of Red Hat Subscription Asset Manager

  • RHSA-2018:2745 Red Hat Product Security13 products fixed

    Red Hat Security Advisory: CloudForms 4.5.5 security, bug fix and enhancement update

  • RHSA-2018:2561 Red Hat Product Security19 products fixed

    Red Hat Security Advisory: CloudForms 4.6.4 security, bug fix, and enhancement update

  • RHSA-2018:2244 Red Hat Product Security24 products fixed

    Red Hat Security Advisory: rh-ror42-rubygem-sprockets security update

  • RHSA-2018:2245 Red Hat Product Security24 products fixed

    Red Hat Security Advisory: rh-ror50-rubygem-sprockets security update

Full record on NVD

Fix

  1. Update sprockets to 4.0.0.beta8 · 3.7.2 · 2.12.5
  2. Vendor fix Red Hat Product Security RHSA-2018:2745 · 13 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258
  3. Vendor fix Red Hat Product Security RHSA-2018:2561 · 19 productsBefore applying this update, make sure all previously released errata relevant to your system have been applied. For details on how to apply this update, refer to: https://access.redhat.com/articles/11258
  4. Workaround from the vendor Red Hat Product Security RHSA-2018:2745 · 13 productsEnsure config.assets.compile = false in production.rb.
  5. No fix planned, says the vendor Red Hat Product Security CVE-2018-3760 · 2 productsWill not fix

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
available
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Published
2018-06-26
Last Modified
2026-06-17
NVD status
Modified
GitHub Advisory
GHSA-pr3h-jjhj-573x

Frequently asked questions

What is CVE-2018-3760?

There is an information leak vulnerability in Sprockets. Versions Affected: 4.0.0.beta7 and lower, 3.7.1 and lower, 2.12.4 and lower. Specially crafted requests can be used to access files that exists on the filesystem that is outside an application's root directory, when the Sprockets server is used in production. All users running an affected release should either upgrade or use one of the work arounds immediately.

Is CVE-2018-3760 actively exploited?

Active exploitation of CVE-2018-3760 has not been confirmed. Its EPSS score was 26.3% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-3760?

CVE-2018-3760 has a CVSS v3 base score of 7.5 (HIGH severity), with vector string CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N.

Running sprockets? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record