Skip to main content
No exploitation reportedFix available

CVE-2018-16841

No exploitation reported by the sources we read.

  • Published2018-11-28
  • WeaknessCWE-415 · CWE-416

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Samba from version 4.3.0 and before versions 4.7.12, 4.8.7 and 4.9.3 are vulnerable to a denial of service. When configured to accept smart-card authentication, Samba's KDC will call talloc_free() twice on the same memory if the principal in a validly signed certificate does not match the principal in the AS-REQ. This is only possible after authentication with a trusted certificate. talloc is robust against further corruption from a double-free with talloc_free() and directly calls abort(), terminating the KDC process.

Timeline

dates in UTC
  1. 2018-11-2814:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-16841?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-16841?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Canonical ubuntu linux
BranchAffectedFixed in
12.4= 12.04no fix published
14.4= 14.04no fix published
16.4= 16.04no fix published
18.4= 18.04no fix published
18.10= 18.10no fix published
Samba
BranchAffectedFixed in
4.9≥ 4.9.0, < 4.9.34.9.3
4.8≥ 4.8.0, < 4.8.74.8.7
4.x≥ 4.3.0, < 4.7.124.7.12
Debian debian linux
BranchAffectedFixed in
9.0= 9.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • cmockaMageia:6all versions · fixed in 1.1.3-1.mga6
  • ldbMageia:6all versions · fixed in 1.2.3-1.mga6
  • sambaUbuntu:18.04:LTSall versions · fixed in 2:4.7.6+dfsg~ubuntu-0ubuntu2.5
  • sambaUbuntu:16.04:LTSall versions · fixed in 2:4.3.11+dfsg-0ubuntu0.16.04.18
  • sambaUbuntu:14.04:LTSall versions · fixed in 2:4.3.11+dfsg-0ubuntu0.14.04.19
  • sambaSUSE:Linux Enterprise Module for Package Hub 15all versions · fixed in 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • sambaSUSE:Linux Enterprise Module for Basesystem 15all versions · fixed in 4.7.11+git.140.6bd0e5b30d8-4.21.1
  • sambaSUSE:Linux Enterprise High Availability Extension 15all versions · fixed in 4.7.11+git.140.6bd0e5b30d8-4.21.1

31 more package ranges on OSV.dev

Full record on NVD

Fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.16.5read 2026-10-23
  • CNACVSS 3.05.7known since 2026-10-23
  • NVDCVSS 2.04read 2026-10-23
  • CNAweakness (CWE)CWE-416known since 2026-10-23
  • NVDweakness (CWE)CWE-415read 2026-10-23
  • FIRST EPSSEPSS score4.6 %2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Published
2018-11-28
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-16841?

Samba from version 4.3.0 and before versions 4.7.12, 4.8.7 and 4.9.3 are vulnerable to a denial of service. When configured to accept smart-card authentication, Samba's KDC will call talloc_free() twice on the same memory if the principal in a validly signed certificate does not match the principal in the AS-REQ. This is only possible after authentication with a trusted certificate. talloc is robust against further corruption from a double-free with talloc_free() and directly calls abort(), terminating the KDC process.

Is CVE-2018-16841 actively exploited?

Active exploitation of CVE-2018-16841 has not been confirmed. Its EPSS score was 4.6% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-16841?

CVE-2018-16841 has a CVSS v3 base score of 6.5 (MEDIUM severity), with vector string CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H.

Running ldb? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record