Skip to main content
ExploitedIn CISA KEVFix available

CVE-2018-15982

Exploitation confirmed. First attested on 2022-02-15 by CISA-ADP, CISA KEV, GCVE · kevintel.

  • Published2019-01-18
  • WeaknessCWE-416

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Flash Player versions 31.0.0.153 and earlier, and 31.0.0.108 and earlier have a use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

Timeline

dates in UTC
  1. 2018-12-24Exploit-DB entryExploit-DB
  2. 2019-01-1817:29CVE publishedNVD
  3. 2022-02-15Added to the CISA KEV catalogCISA KEV
  4. 2022-02-15Listed as exploited by GCVEGCVE
  5. 2022-02-15Exploitation first reportedCISA KEV
  6. 2026-10-0119:46SSVC exploitation set to activeCISA-ADP

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-15982?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-15982?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Adobe flash playerversion to verify
BranchAffectedFixed in
31.0≤ 31.0.0.153no fix published
Adobe flash player installerversion to verify
BranchAffectedFixed in
31.0≤ 31.0.0.108no fix published
Redhat enterprise linux desktop
BranchAffectedFixed in
6.0= 6.0no fix published

2 more products in the sources.

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • flash-player-pluginMageia:6all versions · fixed in 32.0.0.101-1.mga6.nonfree
  • flash-pluginRed Hat:rhel_extras:6all versions · fixed in 0:32.0.0.101-1.el6_10
  • flashplugin-nonfreeUbuntu:18.04:LTSall versions · fixed in 32.0.0.101ubuntu0.18.04.1
  • flashplugin-nonfreeUbuntu:16.04:LTSall versions · fixed in 32.0.0.101ubuntu0.16.04.1
  • flashplugin-nonfreeUbuntu:14.04:LTSall versions · fixed in 32.0.0.101ubuntu0.14.04.1

Vendor advisories

  • CVE-2018-15982 Red Hat Product Security3 products fixed

    flash-plugin: Arbitrary Code Execution vulnerability (APSB18-42)

  • RHSA-2018:3795 Red Hat Product Security3 products fixed

    Red Hat Security Advisory: flash-plugin security update

Full record on NVD

Fix

  1. CISA’s required action: The impacted product is end-of-life and should be disconnected if still in use.due 2022-08-15
  2. Vendor fix Red Hat Product Security RHSA-2018:3795 · 3 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-46051
Exploit-DB
Metasploit modules
none listed
Metasploit Framework

CISA Known Exploited Vulnerability

Date Added
2022-02-15
Patch Due Date
2022-08-15
Ransomware Use
Known
Required Action
The impacted product is end-of-life and should be disconnected if still in use.

Sources

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Published
2019-01-18
Last Modified
2026-10-01
NVD status
Analyzed
GitHub Advisory
GHSA-26v8-ffh8-7vqg

Frequently asked questions

What is CVE-2018-15982?

Flash Player versions 31.0.0.153 and earlier, and 31.0.0.108 and earlier have a use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

Is CVE-2018-15982 actively exploited?

Yes. CVE-2018-15982 is on the CISA Known Exploited Vulnerabilities (KEV) catalog, meaning it has been confirmed as actively exploited in the wild. CISA requires federal agencies to patch by 2022-08-15.

What is the CVSS score for CVE-2018-15982?

CVE-2018-15982 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H.

Running flash-plugin? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record