CVE-2018-1160
A public proof of concept exists; no exploitation attested.
- Published2018-12-20
- Fixed in3.1.12
- WeaknessCWE-787
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
Netatalk before 3.1.12 is vulnerable to an out of bounds write in dsi_opensess.c. This is due to lack of bounds checking on attacker controlled data. A remote unauthenticated attacker can leverage this vulnerability to achieve arbitrary code execution.
Timeline
dates in UTC- 2018-12-2021:29CVE publishedNVD
- 2018-12-21Exploit-DB entryExploit-DB
Observed activity
isMalicious corpus · updated 2026-11-04 09:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-1160?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-1160?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 3.1 | < 3.1.12 | 3.1.12 | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 6.2 | ≥ 6.2, < 6.2.1-23824-4 | 6.2.1-23824-4 | NVD |
| 6.1 | ≥ 6.1, < 6.1.7-15284-3 | 6.1.7-15284-3 | NVD |
| 5.2 | ≥ 5.2, < 5.2-5967-9 | 5.2-5967-9 | NVD |
| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 9.0 | = 9.0 | no fix published | NVD |
3 more products in the sources.
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Products declared by the CNA1 product
As tenable, the CNA that assigned this CVE, declared them in the CVE record; versions as written.
- NetatalkAffected
- = Before 3.1.12no fix stated
Source: the CNA record (CVE Program), © The MITRE Corporation,CVE Terms of UseCVE recordupdated 2019-04-08
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- netatalkUbuntu:18.04:LTSall versions · fixed in 2.2.6-1ubuntu0.18.04.2
- netatalkUbuntu:16.04:LTSall versions · fixed in 2.2.5-1ubuntu0.2
- netatalkUbuntu:14.04:LTSall versions · fixed in 2.2.2-1ubuntu2.2
- netatalkSUSE:Linux Enterprise Workstation Extension 12 SP4all versions · fixed in 3.1.0-3.3.1
- netatalkSUSE:Linux Enterprise Workstation Extension 12 SP3all versions · fixed in 3.1.0-3.3.1
- netatalkSUSE:Linux Enterprise Software Development Kit 12 SP4all versions · fixed in 3.1.0-3.3.1
- netatalkSUSE:Linux Enterprise Software Development Kit 12 SP3all versions · fixed in 3.1.0-3.3.1
- netatalkSUSE:Linux Enterprise Software Development Kit 11 SP4all versions · fixed in 2.0.3-249.23.3.1
24 more package ranges on OSV.dev
Fix
- Update Netatalk to 3.1.12
Advisories and patches
- netatalk.sourceforge.netRelease Notes
- github.comRelease Notes
- www.tenable.comRelease Notes
Detection
read 2026-11-03 22:42 UTC- Nuclei template
- none so far ProjectDiscovery
- Metasploit modules
- none listed Metasploit Framework
Sources
- CISA-ADPSSVC decisionpoc2026-02-13
- OpenCVESSVC decisionpoc—
- CISA-ADPCVSS 3.19.82026-02-13
- NVDCVSS 3.09.8read 2026-10-23
- NVDCVSS 2.010read 2026-10-23
- CISA-ADPweakness (CWE)CWE-7872026-02-13
- CNAweakness (CWE)CWE-787known since 2026-10-23
- NVDweakness (CWE)CWE-787read 2026-10-23
- FIRST EPSSEPSS score86.4 %read 2026-11-03
- PoC-in-GitHubproof of concept1read 2026-11-03
- Exploit-DBdetectionread 2026-11-03
- OSVaffected packages—
- GitHub Advisoriesadvisory—
Identifiers
- EUVD-2018-11798same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-j675-7hvj-qfw5same flawGitHub Advisory Database · CC-BY-4.0
- DSA-4356-1advisory covering several CVEsDebian · LicenseRef-unstated
- MGASA-2019-0061advisory covering several CVEsMageia · LicenseRef-unstated
- SUSE-SU-2018:4214-1advisory covering several CVEsSUSE · LicenseRef-unstated
- SUSE-SU-2018:4217-1advisory covering several CVEsSUSE · LicenseRef-unstated
Technical details
- CVSS v3 Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Published
- 2018-12-20
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-j675-7hvj-qfw5
Frequently asked questions
What is CVE-2018-1160?
Is CVE-2018-1160 actively exploited?
What is the CVSS score for CVE-2018-1160?
Running netatalk? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- Exploit-DB · Exploit-DB terms of service · terms restrict redistribution
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-j675-7hvj-qfw5
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OpenCVE · OpenCVE terms of service · terms restrict redistribution
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- PoC-in-GitHub · CC0-1.0
- CISA Vulnrichment · CC0-1.0