Skip to main content
No exploitation reportedFix available

CVE-2018-1116

No exploitation reported by the sources we read.

  • Published2018-07-10
  • WeaknessCWE-285 · CWE-862

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polkitd allows to test for authentication and trigger authentication of unrelated processes owned by other users. This may result in a local DoS and information disclosure.

Timeline

dates in UTC
  1. 2018-07-1019:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 03:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-1116?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-1116?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Canonical ubuntu linux
BranchAffectedFixed in
12.4= 12.04no fix published
Debian debian linux
BranchAffectedFixed in
8.0= 8.0no fix published
Polkit project polkit
BranchAffectedFixed in
0.115< 0.1150.115

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • policykit-1Ubuntu:18.04:LTSall versions · fixed in 0.105-20ubuntu0.18.04.1
  • policykit-1Ubuntu:16.04:LTSall versions · fixed in 0.105-14.1ubuntu0.1
  • policykit-1Ubuntu:14.04:LTSall versions · fixed in 0.105-4ubuntu3.14.04.2
  • policykit-1Debian:14all versions · fixed in 0.105-21
  • policykit-1Debian:13all versions · fixed in 0.105-21
  • policykit-1Debian:12all versions · fixed in 0.105-21
  • policykit-1Debian:8all versions · fixed in 0.105-15~deb8u3
  • polkitTuxCare:OracleLinux:6all versions · fixed in 0.96-11.el6_10.1.tuxcare.els2and 3 other packages

12 more package ranges on OSV.dev

Full record on NVD

Fix

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.14.4read 2026-10-23
  • CNACVSS 3.04.7known since 2026-10-23
  • NVDCVSS 2.03.6read 2026-10-23
  • CNAweakness (CWE)CWE-285known since 2026-10-23
  • NVDweakness (CWE)CWE-862read 2026-10-23
  • FIRST EPSSEPSS score1.2 %2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L
Published
2018-07-10
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-1116?

A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polkitd allows to test for authentication and trigger authentication of unrelated processes owned by other users. This may result in a local DoS and information disclosure.

Is CVE-2018-1116 actively exploited?

Active exploitation of CVE-2018-1116 has not been confirmed. Its EPSS score was 1.2% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-1116?

CVE-2018-1116 has a CVSS v3 base score of 4.4 (MEDIUM severity), with vector string CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:L.

Running polkit? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record