Skip to main content
Public proof of conceptFix available

CVE-2018-10900

A public proof of concept exists; no exploitation attested.

  • Published2018-07-26
  • WeaknessCWE-78

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.

Timeline

dates in UTC
  1. 2018-08-31Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-03 21:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2018-10900?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2018-10900?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Debian debian linux
BranchAffectedFixed in
8.0= 8.0no fix published
9.0= 9.0no fix published
Gnome network manager vpnc
BranchAffectedFixed in
1.2< 1.2.61.2.6

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • network-manager-vpncUbuntu:18.04:LTSall versions · fixed in 1.2.4-6ubuntu0.1
  • network-manager-vpncUbuntu:16.04:LTSall versions · fixed in 1.1.93-1ubuntu0.1
  • network-manager-vpncUbuntu:14.04:LTSall versions · fixed in 0.9.8.6-1ubuntu2.1
  • network-manager-vpncDebian:13all versions · fixed in 1.2.6-1
  • network-manager-vpncDebian:12all versions · fixed in 1.2.6-1
  • network-manager-vpncDebian:9all versions · fixed in 1.2.4-4+deb9u1
  • network-manager-vpncDebian:8all versions · fixed in 0.9.10.0-1+deb8u1
  • NetworkManager-vpncSUSE:Linux Enterprise Workstation Extension 12 SP3all versions · fixed in 1.0.8-8.4.2

1 more package range on OSV.dev

Vendor advisories

  • CVE-2018-10900 Red Hat Product Security

    NetworkManager-vpnc: privilege escalation allows to execute arbitrary commands as root

Full record on NVD

Fix

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-45313
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
1 moduleexploit/linux/local/network_manager_vpnc_username_priv_escrank: excellentModule metadata: Metasploit Framework, © Rapid7, Inc., BSD-3-Clause.
Metasploit Framework

Sources

  • NVDCVSS 3.17.8read 2026-10-23
  • CNACVSS 3.08.8known since 2026-10-23
  • NVDCVSS 2.07.2read 2026-10-23
  • CNAweakness (CWE)CWE-78known since 2026-10-23
  • NVDweakness (CWE)CWE-78read 2026-10-23
  • FIRST EPSSEPSS score3.9 %2026-11-03
  • Exploit-DBdetectionread 2026-11-02
  • Metasploit FrameworkMetasploit modules1known since 2026-11-01
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
2018-07-26
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2018-10900?

Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.

Is CVE-2018-10900 actively exploited?

Active exploitation of CVE-2018-10900 has not been confirmed. Its EPSS score was 3.9% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2018-10900?

CVE-2018-10900 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H.

Running NetworkManager-vpnc? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record