Skip to main content
No exploitation reportedFix available

CVE-2017-9224

No exploitation reported by the sources we read.

  • Published2017-05-24
  • Fixed in7.1.7 · 7.0.21 · 5.6.31
  • WeaknessCWE-125

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A stack out-of-bounds read occurs in match_at() during regular expression searching. A logical error involving order of validation and access in match_at() could result in an out-of-bounds read from a stack buffer.

Timeline

dates in UTC
  1. 2017-05-2415:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2017-9224?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2017-9224?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
PHP
BranchAffectedFixed in
7.1≥ 7.1.0, < 7.1.77.1.7
7.0≥ 7.0.0, < 7.0.217.0.21
5.6< 5.6.315.6.31
Oniguruma project oniguruma
BranchAffectedFixed in
6.2= 6.2.0no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • libgdMageia:6all versions · fixed in 2.2.4-3.1.mga6
  • libgdMageia:5all versions · fixed in 2.2.4-1.2.mga5
  • libonigUbuntu:16.04:LTSall versions · fixed in 5.9.6-1ubuntu0.1
  • libonigUbuntu:14.04:LTSall versions · fixed in 5.9.1-1ubuntu1.1
  • libonigDebian:14all versions · fixed in 6.1.3-2
  • libonigDebian:13all versions · fixed in 6.1.3-2
  • libonigDebian:12all versions · fixed in 6.1.3-2
  • libonigDebian:7all versions · fixed in 5.9.1-1+deb7u1

35 more package ranges on OSV.dev

Vendor advisories

  • RHSA-2018:1296 Red Hat Product Security254 products fixed

    Red Hat Security Advisory: rh-php70-php security, bug fix, and enhancement update

Full record on NVD

Fix

  1. Update PHP to 7.1.7 · 7.0.21 · 5.6.31
  2. Vendor fix Red Hat Product Security RHSA-2018:1296 · 254 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 After installing the updated packages, the httpd daemon must be restarted for the update to take effect.

Advisories and patches

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.19.8read 2026-10-23
  • NVDCVSS 2.07.5read 2026-10-23
  • NVDweakness (CWE)CWE-125read 2026-10-23
  • FIRST EPSSEPSS score6.5 %2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
2017-05-24
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2017-9224?

An issue was discovered in Oniguruma 6.2.0, as used in Oniguruma-mod in Ruby through 2.4.1 and mbstring in PHP through 7.1.5. A stack out-of-bounds read occurs in match_at() during regular expression searching. A logical error involving order of validation and access in match_at() could result in an out-of-bounds read from a stack buffer.

Is CVE-2017-9224 actively exploited?

Active exploitation of CVE-2017-9224 has not been confirmed. Its EPSS score was 6.5% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2017-9224?

CVE-2017-9224 has a CVSS v3 base score of 9.8 (CRITICAL severity), with vector string CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H.

Running rh-php70-php security, bug fix,? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record