CVE-2017-16082
A public proof of concept exists; no exploitation attested.
- Published2018-06-07
- Fixed in7.1.2 · 7.0.2 · 6.4.2 · 6.3.3 · 6.2.5 · 6.1.6
- WeaknessCWE-94
Am I affected?
Debian, Ubuntu or Red Hat sometimes backport a fix without changing the upstream version number: such a version reads « to verify », never « affected ».With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.
Description
A remote code execution vulnerability was found within the pg module when the remote database or query specifies a specially crafted column name. There are 2 likely scenarios in which one would likely be vulnerable. 1) Executing unsafe, user-supplied sql which contains a malicious column name. 2) Connecting to an untrusted database and executing a query which returns results where any of the column names are malicious.
Timeline
dates in UTC- 2018-06-0702:29CVE publishedNVD
Observed activity
isMalicious corpus · updated 2026-11-03 15:37 UTCBlock these indicators
- Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2017-16082?format=txt
- CSV export: https://api.ismalicious.com/edl/cve/CVE-2017-16082?format=csv
- TAXII collection of exploited CVEs
- The EDL and CSV take an API key on the Pro plan.
Versions per branch
NVD · OSV| Branch | Affected | Fixed in | Source |
|---|---|---|---|
| 7.x | ≥ 7.0.0, < 7.1.2 | 7.1.2 | NVD |
| 7.1 | ≥ 7.1.0, < 7.1.2 | 7.1.2 | OSV |
| 7.0 | ≥ 7.0.0, < 7.0.2 | 7.0.2 | OSV |
| 6.x | ≥ 6.0.0, < 6.4.2 | 6.4.2 | NVD |
| 6.4 | ≥ 6.4.0, < 6.4.2 | 6.4.2 | OSV |
| 6.3 | ≥ 6.3.0, < 6.3.3 | 6.3.3 | OSV |
| 6.2 | ≥ 6.2.0, < 6.2.5 | 6.2.5 | OSV |
| 6.1 | ≥ 6.1.0, < 6.1.6 | 6.1.6 | OSV |
| 6.0 | ≥ 6.0.0, < 6.0.5 | 6.0.5 | OSV |
| 5.x | > 5.0.0, < 5.2.1 | 5.2.1 | NVD |
| 5.x | ≥ 5.0.0, < 5.2.1 | 5.2.1 | OSV |
| 4.x | ≥ 4.0.0, < 4.5.7 | 4.5.7 | NVD · OSV |
as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.
Distribution builds and vendor advisories
Packages from OSV.dev and products from the vendors' CSAF advisories.
version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.
Packages
- node-postgresUbuntu:16.04:LTSall versions · no fixed version listed
- node-postgresDebian:14all versions · fixed in 7.7.1-1
- node-postgresDebian:13all versions · fixed in 7.7.1-1
- node-postgresDebian:12all versions · fixed in 7.7.1-1
Fix
- Update Node-postgres pg to 7.1.2 · 7.0.2 · 6.4.2 · 6.3.3 · 6.2.5 · 6.1.6 · 6.0.5 · 5.2.1
Detection
read 2026-11-02 22:42 UTC- Nuclei template
- none so far ProjectDiscovery
- Exploit-DB
- no entry Exploit-DB
- Metasploit modules
- none listed Metasploit Framework
Sources
- NVDCVSS 3.09.8read 2026-10-23
- NVDCVSS 2.07.5read 2026-10-23
- CNAweakness (CWE)CWE-94known since 2026-10-23
- NVDweakness (CWE)CWE-94read 2026-10-23
- FIRST EPSSEPSS score10.5 %read 2026-11-02
- PoC-in-GitHubproof of concept1read 2026-11-02
- OSVaffected packages—
- GitHub AdvisoriesadvisoryCRITICAL2020-06-16
Identifiers
- EUVD-2018-0331same flawENISA EUVD · LicenseRef-ENISA-legal-notice
- GHSA-wc9v-mj63-m9g5same flawGitHub Advisory Database · CC-BY-4.0
Technical details
- CVSS v3 Vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Published
- 2018-06-07
- Last Modified
- 2026-06-17
- NVD status
- Modified
- GitHub Advisory
- GHSA-wc9v-mj63-m9g5
Frequently asked questions
What is CVE-2017-16082?
Is CVE-2017-16082 actively exploited?
What is the CVSS score for CVE-2017-16082?
Running node-postgres? Hear about its next vulnerability
Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».
No credit card required · No monthly cap on website lookups · 250 API requests/month
Go further
- Following what attackers exploit right now? The CISA KEV additions of the month, with their patch deadlines.
- Running this software? Vulnerability monitoring alerts you to new vulnerabilities in your products.
Related vulnerabilities
Same product first, then the same vendor advisory and the same publication week.
Sources for this record
- CVE Program · CVE Program Terms of Use
- ENISA EU Vulnerability Database · ENISA legal notice §1.2 (reproduction authorised, provided the source is acknowledged)
- FIRST EPSS · EPSS terms of use (free use, attribution requested)
- GitHub Advisory Database · CC-BY-4.0 · GHSA-wc9v-mj63-m9g5
- NVD · Public domain (17 U.S.C. § 105) for NVD-authored data; third-party content under its own terms
- OSV.dev · Per record, as its publisher states it: each row carries the label in sourceLicense when one is served
- PoC-in-GitHub · CC0-1.0