Skip to main content
No exploitation reportedFix available

CVE-2017-11628

No exploitation reported by the sources we read.

  • Published2017-07-25
  • WeaknessCWE-119

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

In PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, a stack-based buffer overflow in the zend_ini_do_op() function in Zend/zend_ini_parser.c could cause a denial of service or potentially allow executing code. NOTE: this is only relevant for PHP applications that accept untrusted input (instead of the system's php.ini file) for the parse_ini_string or parse_ini_file function, e.g., a web application for syntax validation of php.ini directives.

Timeline

dates in UTC
  1. 2017-07-2523:29CVE publishedNVD

Observed activity

isMalicious corpus · updated 2026-11-04 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2017-11628?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2017-11628?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
PHP
BranchAffectedFixed in
5.6≤ 5.6.30no fix published
7.0= 7.0.0no fix published
7.0= 7.0.1no fix published
7.0= 7.0.2no fix published
7.0= 7.0.3no fix published
7.0= 7.0.4no fix published
7.0= 7.0.5no fix published
7.0= 7.0.6no fix published
7.0= 7.0.7no fix published
7.0= 7.0.8no fix published
7.0= 7.0.9no fix published
7.0= 7.0.10no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • php5Ubuntu:14.04:LTSall versions · fixed in 5.5.9+dfsg-1ubuntu4.22
  • php5SUSE:Linux Enterprise Software Development Kit 12 SP3all versions · fixed in 5.5.14-109.5.1
  • php5SUSE:Linux Enterprise Software Development Kit 12 SP2all versions · fixed in 5.5.14-109.5.1
  • php5SUSE:Linux Enterprise Module for Web and Scripting 12all versions · fixed in 5.5.14-109.5.1
  • php5Debian:8all versions · fixed in 5.6.33+dfsg-0+deb8u1
  • php5Debian:7all versions · fixed in 5.4.45-0+deb7u10
  • php53SUSE:Linux Enterprise Software Development Kit 11 SP4all versions · fixed in 5.3.17-112.5.1
  • php53SUSE:Linux Enterprise Server for SAP Applications 11 SP4all versions · fixed in 5.3.17-112.5.1

8 more package ranges on OSV.dev

Vendor advisories

  • RHSA-2018:1296 Red Hat Product Security254 products fixed

    Red Hat Security Advisory: rh-php70-php security, bug fix, and enhancement update

Full record on NVD

Fix

  1. Vendor fix Red Hat Product Security RHSA-2018:1296 · 254 productsFor details on how to apply this update, which includes the changes described in this advisory, refer to: https://access.redhat.com/articles/11258 After installing the updated packages, the httpd daemon must be restarted for the update to take effect.

Detection

Nuclei template
none so far
ProjectDiscovery
Exploit-DB
no entry
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.07.8read 2026-10-23
  • NVDCVSS 2.06.8read 2026-10-23
  • NVDweakness (CWE)CWE-119read 2026-10-23
  • FIRST EPSSEPSS score3.4 %2026-11-03
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Published
2017-07-25
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2017-11628?

In PHP before 5.6.31, 7.x before 7.0.21, and 7.1.x before 7.1.7, a stack-based buffer overflow in the zend_ini_do_op() function in Zend/zend_ini_parser.c could cause a denial of service or potentially allow executing code. NOTE: this is only relevant for PHP applications that accept untrusted input (instead of the system's php.ini file) for the parse_ini_string or parse_ini_file function, e.g., a web application for syntax validation of php.ini directives.

Is CVE-2017-11628 actively exploited?

Active exploitation of CVE-2017-11628 has not been confirmed. Its EPSS score was 3.4% on 2026-11-03, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2017-11628?

CVE-2017-11628 has a CVSS v3 base score of 7.8 (HIGH severity), with vector string CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H.

Running rh-php70-php security, bug fix,? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record