Skip to main content
Public proof of conceptFix available

CVE-2016-6505

A public proof of concept exists; no exploitation attested.

  • Published2016-08-06
  • WeaknessCWE-369

Am I affected?

With a domain, we read the version its public headers and pages expose. A distribution build can carry the fix under an older number.

Description

epan/dissectors/packet-packetbb.c in the PacketBB dissector in Wireshark 1.12.x before 1.12.13 and 2.x before 2.0.5 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted packet.

Timeline

dates in UTC
  1. 2016-08-03Exploit-DB entryExploit-DB

Observed activity

isMalicious corpus · updated 2026-11-03 09:37 UTC
Indicators tagged with this CVE, per day0 indicators over 7 days
Block these indicators
  • Firewall list (EDL, text): https://api.ismalicious.com/edl/cve/CVE-2016-6505?format=txt
  • CSV export: https://api.ismalicious.com/edl/cve/CVE-2016-6505?format=csv
  • TAXII collection of exploited CVEs
  • The EDL and CSV take an API key on the Pro plan.

Versions per branch

NVD
Wireshark
BranchAffectedFixed in
1.12= 1.12.0no fix published
1.12= 1.12.1no fix published
1.12= 1.12.2no fix published
1.12= 1.12.3no fix published
1.12= 1.12.4no fix published
1.12= 1.12.5no fix published
1.12= 1.12.6no fix published
1.12= 1.12.7no fix published
1.12= 1.12.8no fix published
1.12= 1.12.9no fix published
1.12= 1.12.10no fix published
1.12= 1.12.11no fix published

as publishedRanges as NVD and OSV publish them; a distribution’s build can be fixed under an older number.

Distribution builds and vendor advisories

Packages from OSV.dev and products from the vendors' CSAF advisories.

version not verifiedVersions not verified: read as OSV.dev and the vendors publish them, not checked against each vendor's release list.

Packages

  • wiresharkUbuntu:16.04:LTSall versions · fixed in 2.2.6+g32dac6a-2ubuntu0.16.04
  • wiresharkUbuntu:14.04:LTSall versions · fixed in 1.12.1+g01b65bf-4+deb8u11ubuntu0.14.04.1
  • wiresharkSUSE:Linux Enterprise Software Development Kit 12 SP1all versions · fixed in 1.12.13-31.1
  • wiresharkSUSE:Linux Enterprise Software Development Kit 11 SP4all versions · fixed in 1.12.13-0.23.1
  • wiresharkSUSE:Linux Enterprise Server for SAP Applications 12 SP1all versions · fixed in 1.12.13-31.1
  • wiresharkSUSE:Linux Enterprise Server for SAP Applications 11 SP4all versions · fixed in 1.12.13-0.23.1
  • wiresharkSUSE:Linux Enterprise Server 12 SP1all versions · fixed in 1.12.13-31.1
  • wiresharkSUSE:Linux Enterprise Server 11 SP4all versions · fixed in 1.12.13-0.23.1

10 more package ranges on OSV.dev

Full record on NVD

Fix

Advisories and patches

Detection

read 2026-11-02 22:42 UTC
Nuclei template
none so far
ProjectDiscovery
Exploit-DB
EDB-40197
Exploit-DB
Proof-of-concept repositories
none listed
PoC-in-GitHub
Metasploit modules
none listed
Metasploit Framework

Sources

  • NVDCVSS 3.05.9read 2026-10-23
  • NVDCVSS 2.04.3read 2026-10-23
  • NVDweakness (CWE)CWE-369read 2026-10-23
  • FIRST EPSSEPSS score7.7 %2026-11-02
  • Exploit-DBdetectionread 2026-11-02
  • OSVaffected packages—

Identifiers

Technical details

CVSS v3 Vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
2016-08-06
Last Modified
2026-06-17
NVD status
Modified

Frequently asked questions

What is CVE-2016-6505?

epan/dissectors/packet-packetbb.c in the PacketBB dissector in Wireshark 1.12.x before 1.12.13 and 2.x before 2.0.5 allows remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted packet.

Is CVE-2016-6505 actively exploited?

Active exploitation of CVE-2016-6505 has not been confirmed. Its EPSS score was 7.7% on 2026-11-02, the estimated probability of exploitation in the next 30 days.

What is the CVSS score for CVE-2016-6505?

CVE-2016-6505 has a CVSS v3 base score of 5.9 (MEDIUM severity), with vector string CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H.

Running wireshark? Hear about its next vulnerability

Surveillance reads the versions in your stack — a domain, a lockfile or a list — checks each CVE against the ranges its sources publish, and alerts you when one you run is exploited or enters CISA KEV. A version it cannot read stays « version not verified ».

No credit card required · No monthly cap on website lookups · 250 API requests/month

Sources for this record